Restore - from - Backup

My data seems to be lost.
I have multiple backups on Time Machine and on Carbon Copy Cloner with Safety Net
I’m not sure i understand the description in the Help documents.
I need to restore or recreate from a backup and have so far been unsuccessful
Please describe in detail how to proceed. I want the backup to become my current database (even though I lose what I may have added since).
In the case of Time Machine can I restore the database file in the devonthink database folder to the desktop to work with it?

thank you

If you go to the folder you had the databases, then go into the Time Machine interface, you should be able to restore the database and overwrite the current copy. You could also Control-click the database in Time Machine and choose Restore to, restoring it to a different location.

I restored from Time Machine a 264mb file with the correct name to the devonthink database folder. I said overwrite and it said it coudn’t because there is a file with the same name. So I tried again and said keep both, it said it coudn’t because there was a file by the same name but it changed the name of the original adding “original”. I said open database and it said a file by the same name is already in use, I said continue but nothing came up. I tried to replaced the whole Devonthink database folder, it said it couldn’t complete because another database in the folder with the same name was there, nevertheless it replaced the folder. Strangely althugh I copied a file with 264MB. only 247 appear in the devonthink database folder. Anyway, as with all attempts to Open Database from the file menu didn’t open anything.
In the open recent there are several files available with similar names just different dates. They look like the folder in the ~users/databases folder where some time during this process I moved a file.
I am at a loss and need urgent help

Restore from an older TimeMachine version?

Compress the database file, upload it to a cloud account like Dropbox, and send me the link in your support ticket.

Sent by mail. no longer in my outbox

Also added to dropbox
Shared. Sent an email to support with the ticket number
Don’t know if link sent
Please advise

Got it. Thanks.
I’m working on my response right now.


REVISED: I just had a similar issue: could not copy ”Inbox.dtBase2” from any TimeMachine backup to /ANY/ location because – supposedly – a file by that name already existed (yes, even though DT3 was closed). Effectively, I was informed could not restore anything that may have been removed… HOWEVER, after closing 2 instances of DTtG to make sure the database was closed, I discovered that the old database had in fact been copied to the new location, and DT3 opened it, allowing me to replicate files from it to the current database! Quite a surprise (and may have had nothing to do with DTtG)!

DEVONthink To Go shouldn’t have had any effect as the devices are independent of one another. I think this was merely coincidental.

However I’m glad you got something worked out.