RSS feeds in DTPO

I have tried to import a feed into DTPO by data-new-feed and then paste the feed address in the pop-up menu after removing the “feed://”. The address of the feed is:

However, the feeds are not downloading into DTPO. I have tried the same adress in Reeder, the currently stand alone app for managing my feeds, and it correctly download 14 articles. Is there a bug in the RSS functionality of DTPO?

This is correct, the url-field should like that with the address:
Screen Shot 2013-03-10 at 22.58.22.jpg

Here it works as expected and DEVONthink downloads 13 hmtl files and 1 bookmark file.

I suggest, you empty DEVONthink’s cache from the menue bar > DEVONthink Pro > “Empty Cache”, restart DEVONthink and choose “refresh feed” from the context-menu (ctrl-click on the feed’s icon). If that doesn’t help, delete the feed, empty the trash, create the feed again. If the feed is still not loading, I’d reboot the Mac.

I have tried all of your solutions, several times, without being able to load feeds.

Anyone else who have suggestions?

I figured it out myself, however, I don´t know why it worked :unamused:

I manually trashed the cache and the preference files for DTPO in Library :smiley: