Scan preview pane is always empty, please help - OSX 10.6

Seems that when I try to scan a document File>Import>Document (via Image Capture) the scanner warms up and runs over the page initially. However the scan preview image is blank. I have to click on the empty space to get the crop drag handles to display, then drag them over the entire empty box. hit scan and it works.

however this is not efficient, i find my self opening all the documents i’ve already scanned just to crop and adjust them. its very time consuming.

see screenshot:

Does this also happen using the Image Capture application? Has been anything logged to the system console while scanning (see /Applications/Utilities/

Image capture preview works fine. Will check console and post results

Same thing is happening to me. Image Capture works just fine for me as well, but DTPO is not.

And, I can’t see that anything has been logged in the Console Messages either.

I have exactly the same problem.

My scanner is a Brother DCP-7030, it’s a multifunctional (printer/scanner). Image Capture works perfectly fine but when I try to use “File>Import>Document (via Image Capture)”, I get the same blank screen that riegersn1 showed.

I still don’t know what is the problem. Couldn’t find anything relevant in the Console logs.

Is there any info I could provide that could probably help in getting to a solution?

A workaround that can handle scanners that are not compatible with DTPO’s ExactScan or Image Capture scanner controllers is via a Folder Action script:

  1. Create a new Finder folder that is to receive your scanner’s output. For the sake of illustration, I’ll call that folder “Harry”.

  2. In the Finder, Control-click on “Harry” and choose the contextual submenu “Services”, then select “Folder Actions Setup”.

  3. Choose the script named “DEVONthink - Import, OCR & Delete”. (It should be listed among the available options. It is located at ~/Library/Scripts/Folder Action Scripts/.

  4. Attach that script to “Harry”.

Now operate your scanner using its provided driver software after configuring it to save scanner output to “Harry”. DT Pro Office should be running.

Each time a new scanner output file is saved into “Harry”, the attached Folder Action script will send it to DT Pro Office for OCR and storage of the resulting searchable PDF, then send the original image file to the Trash. The folder “Harry” will therefore be emptied as each image-only PDF is sent to it and then forwarded to DT Pro Office for Import and OCR.

Especially if the new file sent to “Harry” is a large one, nothing may seem to have happened for a time. To verify that the script has sent the image file to DT Pro Office for OCR, switch to DT Pro Office and choose in the menubar Window > OCR Activity. When processing is complete, the script will then delete the image file from “Harry”.

Same problem here.

I use an Epson Perfection V350 Photo scanner which works perfectly with Image Capture.
First the scanner seems to be working fine if used by the “File>Import>Document (via Image Capture)” command, but when it comes to the point of actually scanning a preview, things go wrong. The carriage of the scanner moves too fast. Scanning a preview with Image Capture lets the carriage move much more slowly. In fact it is moving as fast as if returning to the starting point after a scan.

Please let me know what I can do to help resolving the issue. I will check back often because I want this to be resolved.

I’m using the latest version of DEVONthink Pro Office 2.1.1 on a MacBook Pro running OS X 10.6.8

Edit: There hasn’t been logged anything to the system console while scanning.

OK, two weeks have passed now.
A few days ago DEVONthink Pro Office was updated to version 2.2 and today OS X Lion 10.7 was released. Unfortunately, both updates brought no changes. The scanner still doesn’t work with DEVONthink Pro Office, although it does with Image Capture.

Thanks @Bill_DeVille for the folder action script workaround. This really helps a lot!

But still… :wink:

I’m having the same problem, a blank window/preview in the DT Image Capture, and when asking it to scan it starts, then freezes the scanner.

Apple Image Capture works fine so I’ve tried to us the Folder Action to move a document directly into DT, but hit a problem with multi page scans.

I can get two pages into DT and no more, the action is picking up the document and moving it into DT before I’ve finished scanning pages. Many of my scans are multipage so I’ve had to abandon this method of capture.

I’m on Lion, and I’ve lost Exactscan which has been my preferred capture app. I suspect the problem is something to do with Epson drivers being PPC and unsupported in Lion, but fortunately Image Capture is working.

I think we can rule that out, because Apple removed Rosetta (the PPC compatibility layer) in Lion.

I don’t think I made myself clear, I suspect the problem with ‘my’ system, Epson 2400, is to do with the PPC drivers. I’ve just been through my system with a magnifying glass as detailed on this thread: viewtopic.php?f=3&t=13626

When 10.6 SL was released my scanner stopped working except in the Mac Image Capture, Exactscan also stopped working, along with Acrobat and a couple of other programs. The problem with the DT Image Capture stared for me back then too, but on the Exactscan site there are instructions to fix their app by forcing the Exactscan app to run as PPC using Rosetta. This took some finding as DT use a different app, but I eventually tracked the location down and forced it to use Rosetta. This has worked perfectly for me until Lion, I could either use Exactsan through DT, or use the Mac Image Capture app. I couldn’t use most other apps unless they use Mac Image Capture, and that includes the DT Image Capture module.

With Lion the Mac Image Capture works, but nothing else does. Exactsan would not launch because somehow the force PPC flag transferred across into Lion, and DT Image Capture doesn’t work. I’ve eventually tracked down the Launchservices.plist, and edited it to allow Exactscan to work as x86, but because the Epson drivers are/were PPC I can no longer see any scanners through this app. There are obscure references to Epson scattered about in my Library file that I’ve not deleted in this quest so far, my suspicion is that some of these may reference the deleted Epson PPC drivers, and may be causing a problem with the DT Image Capture app in my system.

My suggestion to DT would be to remove the DT image capture, and have the call invoke the Mac Image Capture, which while inelegant compared to Exactscan is usable, and possibly the only option for some. In my case it works perfectly well, and is certainly comparable or better than the DT Image Capture module.

I have taken a different route to cure my scanning woes having ordered a new multifunction HP device (for little more than twice the cost of a new set of ink cartridges which I needed anyway!). The hope is that I can once again scan via either Exactscan or Acrobat, both superior options to Image Capture. I won’t know if this will improve my situation until Friday. :question:

I thought I’d update with the situation on my machine now I’ve a new scanner installed, a 6500a HP All in one.

I’ve only got the Apple drivers, HP’s installer for it’s own are locked away with a ‘need to have 10.6’ message, and it could be a wait for those!

Apple’s Image Capture works fine, DT Image Capture says no scanner found, and offers to let you browse for a scanner, and launches the Apple Image Capture application when you select browse. This launches a scan which appears to work correctly but crashes the whole DT app when you would expect the scan to have completed. This is not the case when using Image Capture as a stand alone, that works fine with the exception of setting a folder action moving the scan too early. It is fully usable on it’s own.

A suggestion in Adobe’s Acrobat forum to use the latest Acrobat X software has drawn a blank too, as with my older V9 this cannot see any scanners installed, along with DT Image Scan and Exactscan. I don’t think that I’ll see these work until the official HP drivers are installed.

Apple Image capture is obviously usable on it’s own, but is far from my favorite way to use the scanner, fortunatly however, the scanner on its own is able to do a better job by working stand alone. It cannot see the Mac, it needs the HP drivers I can’t install for that, but can scan to it’s own SD card which it shares to the network. It is now a no brainer to feed a scan through the machine itself and just pick up the file directly in DT or any other application.

I’ll post back when I finally get to give the updated HP driver a go if now fix at the DT end is found.

I have the same issue with a Canon CanoScan Lide 210 and I’m wondering wether this issue will be getting addressed by the developers or wether it will always be necessary to work with Folder Actions (which would be not very good).