Search bar autocomplete


Recently I’ve had a strange autocompletion issue in the DT Search Bar. Whenever I type a word that ends with an apostrophe and the letter S, such as “harry’s” or “john’s” (without the quotes), the field immediately completes it to “harry’service” or “john’service”. I have no idea where this comes from, I’ve never searched for anything remotely similar. I’ve tried clearing the Recent Searches and restarting DT but it doesn’t help. What is this autocompletion based on and how can I remove it?


In case of disabled partial matches and disabled live searching the field supports autocompletion. Do you use any of these options?

No, I have disabled both. I don’t mind autocompletion, but what is it based on? I’ve never typed anything like “*'service”.

It’s based on the indexed contents and uses the most frequent words.

Well in my case it’s not being helpful :slight_smile:

But I’ve enabled “Live while typing” to avoid this in the meantime, so that’s OK. Not a very clear behavior IMHO.