Send by email does not Work anymore

Hi, all of a sudden, the ‘Send by email’ function does not work anymore. When I use the contextual menu or the button in the toolbar, Devon switches to Apple Mail, but it won’t create a new message nor does it attach the selected document(s).
Other strange thing is that for some specific downloaded pdf-files, these file had be to saved to some folder (using Export > Files and folders) and then attach it in a Mail-message using the Attachments-button in Mail; I could not get it dragged and dropped directly from DTPO to a new mail message.
However, for other pdf’s that were created using the scanner (ScanSnap), the drag n drop did function as expected.

The Send by email function used to work perfectly, don’t know what might have changed this.

After this I checked for updates, DevonThinkPro now has version 2.11.3. Issue persists.

Working on a MacPro 2013 running Mojave 10.14.3
Apple Mail Version 12.2 (3445.102.3)
Have restarted the Mac, restarted DTPO, restarted Apple Mail. No difference.

Any idea what the issue can be?

Thnx,
Henk-Jan

Do you have Full Disk Access and Automation enabled for DEVONthink in System Preferences > Security & Privacy > Privacy?

There is an issue with how Apple Mail interprets the incoming data from DEVONthink. If there’s a URL on a file, Mail is using that instead of the file itself.

Jim, thanks for your reply. Unfortunately, DTPO added to the Full Disk Access, restarted the system, but still the same. Mail is opened or if open already, the active window switches to Mail, but no new message is created.

Do you use any third-party plug-ins for Apple Mail?

No, no 3rd party mail plug-ins, just DEVONThink.mailbundle

Is DEVONthink Pro Office able to automate Mail, see System Preferences > Security & Privacy > Automation?

THANKS! Mail was not ticket there, and now it works as it should!
Strange however, I have never touched that option, and Send by mail used to work.

Anyhow, thanks again, topic closed.