Services menu

i am a new user using Safari as my web browser. For some strange reason when I select part of a web page I would like to turn into a note when I go to services it is all greyed out. In fact every sub menu in Services is greyed out.

I have tried this in word documents etc and still get the same problem. Has anyone any idea’s?




You need to download and install the free Services package that’s available from the DevonThink site. Place the files in your User:Library:Services folder, and the Services menu will no longer be grayed out.

As you install other software, some of them will add items to the Services menu. To maintain greater control over that menu, use a free utility called Services Scrubber, available from VersionTracker.


Hi Will

Thanks for the reply.

I have downloaded and installed the services on the download page on free applications and services into my home/libary/services. I then rebooted. I am still in the same position - its all greyed out.

I take it to copy something i just highlight the subject with the mouse then go to devon think - services - take rich note.

Thanks for your help.


Yes, that’s how it’s supposed to work.

The free services that you installed in /[you-sir]/Library/Services are not the ones that copy text into DT but services that the DEVON people have made for general use. The DT-specific services you are looking for are part of the DT application and were automatically loaded into the Services menu when you installed DT.

Are you able to select text and use non-DT services? For example, the TextEdit services? If not, you may have a damaged user. Try creating a new user and see if services work for that.


Yes I find that I can drag content from a web page into a TextEdit box.

I have tried reloading the software without luck. The only part i have not loaded is the automator scripts as I don’t use these.



Hi, Simon:

Do you have DT Pro installed in your Applications folder? That’s necessary for Services to work.

Also, after installing a new application it’s necessary to restart or logout/login before the Services can work for that application.

Services will work for Safari, which is a Cocoa application. But Services will not work with MS Word, which is not Services-aware.

For transferring selected text from Word to DT Pro you can either drag the selected text to the DT Pro icon in the Dock or (better) drag the selected text to DT Pro’s floating Groups panel, which will let you choose the destination group. (The Groups panel is available by selecting Tools > Show Groups. The Groups panel can be minimized to the Dock when not in use.)

You can “drag content to TextEdit” but can you copy it via TextEdit’s services?


Yes I can copy it to DTP via the services of TextEdit, its not greyed out.


Do you use any Safari extensions/hacks?

Hi christian

I have gone to Safari and looked at the services and everything is greyed out.


Is there anything special about your system? Because that’s of course not the usual behaviour of Safari.


I just checked my safari preferences and changed style sheet on advanced to" other" I then closed preferences and everything is working as it should!!

I dont know what this did but thanks to everyone who has helped me with this problem, you’re help is much appreciated.’:D’