Set Name As: Clever! Kudos!

Did not know this:

While reading an RTF, I selected a few words and wanted them as a title. If I right click on the highlighted words and click “Set Name As,” that becomes the title of the document. Nice!

(If I’m the last in the Devnothink world to figure this out…what can I say? :stuck_out_tongue:)

(I use mostly RTF, but tried this on a PDF and still worked)


You’re definitely not the last to find out… and there are always little gems like this to discover in DEVONthink.

I didn’t know this either!

Very hand when you want to “sync” the DEVONthink title from a title in in-text metadata of a Markdown document. Here the beginning of an example Markdown document:

Title: Hybrid watches - Overview
Base Header Level:  2
CSS: /_resources/default.css

# [%Title]

Just highlight Hybrid watches - Overview, press Ctrl-Cmd-i and you are done! :slight_smile:

A little gem, yes, but a shiny one nonetheless as this is a function one has to use over and over again.

Because of that I have set the simpler to type F5 to trigger Set Name As.

Scrivener has the same function but under a different name. I set F5 to trigger it too. So at least in these two intensively used programs quite a long time ago it has become part of my muscle memory to select a part of of a document with one hand and to afterwards hit F5 to rename the document.

I can only select one of the marked words and use this for file name. How can I select more than one?

Thank you for any help

This is impossible to say without more information. If you’re referring to a PDF, it could be the text layer isn’t fully intact.

Yes, PDF. I use the build in function of DT to OCR the file. Could it be a MacOS Catalina issue?

Not a macOS Catalina issue. I just used DT3 to OCR a document to searchable PDF. I can select more than one word and set it as title using this nifty function.

Ok, thanks. I must investigate further whats wrong. Probably the problem is sitting in front of the machine. :smile:

I tried with a RTF I created with the words of your post. Only the first word I marked is used for the file name.

In the example shown document.rtf is then renamed to Catalina.rtf
My DT Version is 3.0.1

That is unsupported (and honestly the first time I’ve ever seen anyone try to use non-contiguous selections).

@cgrunenberg would have to assess if this is feasible or not.

For what it’s worth, that would be a really useful feature, if possible.

My naming structure sees Surname_Title_Year/Date. It would often be possible to select that detail from the first page of a PDF, but it would most likely need to be a non-contiguous selection.

@BULFROG : thank you for clarification

The PDFkit of macOS doesn’t support such selections.

How explicitely did you set F5 to do this?
Normal “keyboard shortcuts” settings in OSX or special app?

Ah also found this Keyboard shortcut for Set Name As?

Just MacOS settings.