Set Title As shortcut deletes text from web archive

When I select text in a web archive and choose the script “Set Title As” (called “Set Title As___Ctrl-Alt-T.scpt” in my menu) from the Scripts>Rename menu, it works as expected.

If, however, I choose to use the keyboard shortcut of control-option-t, the text in the web archive is deleted. I think this has been true for several beta versions.


OS X (10.5.8)
DEVONthink Pro 2.0pb6

That’s true. Scripts > Rename lists three scripts, each with a keyboard shortcut, to rename a document using selected text. I didn’t examine the scripts, but I tried all three to rename a WebArchive document. The first and third scripts worked correctly using their keyboard shortcuts.

The second of the three scripts shows a keyboard shortcut, Control-Option-T.

If I select text in a WebArchive document and click on the script in the Scrips menu, that script works correctly.

But if I use the keyboard shortcut, Control-Option-T, the document is renamed BUT the selected text is deleted.

So – there appears to be something weird about the keyboard shortcut, not the script itself.

Here, in 2.0pb6, it’s still Control-Option-Command-T.

The shortcut should actually be Cmd-Ctrl-Option-T and is working fine over here.

After some poking around and following links, I realized I’d used the Keyboard Shortcuts preferences pane to assign Cmd-Ctrl-Alt-T to Tables… . I swapped those around and everything seems to be working now.