Shortcuts: Get DEVONthink item with UUID failing

I have a shortcut that I have used for some time that suddenly failed on my iPhone today. The shortcut itself is long, but it fails right up front when I try to get an item using a UUID. The specific error is: No item found for provided UUID or item link.

So I opened DTTG, checked the UUID and it is (still) correct.
Next I created a MD link to that item and I can successfully open that MD link on iPhone, iPad, and Mac.

Next I created a one line shortcut:

It fails in the same way on my iPhone.

Next I went to my iPad mini expecting the same problem, but to my surprise everything worked fine there.

So, I went back to the iPhone and restarted it but I still have the same errors.

So, to summarize:

  1. I had a working shortcut that stopped working today;

  2. I created a one line shortcut, to encapsulate the error, that fails on my iPhone but works on my iPad mini (both running 16.5);

  3. the corresponding MD link Receipt, Mariela <link is: x-devonthink-item://A6BD43DB-BA0B-4D5B-9A55-FAE76B15E80D> works on all platforms.

Can anyone suggest a reason why a shortcut could fail to get an item with a good UUID on one device, but not another.

Does the item-linked item actually exist on the problematic device? I’m seeing no issue here.

Yes it does Jim.

That’s what I was trying to indicate when I said that the MD link works on all my platforms indicating that the document is present in all cases.

Just to be clear - I normally run this shortcut from my iPhone and ran it last week with no issues. Something has changed but I haven’t made any changes to this shortcut, or the database, that I am aware of to cause this changed behavior.

And then it runs ok on my iPad?! … go figure.

What OS and version of DEVONthink To Go?

iOS and iPadOS both 16.5

but DTTG versions are different on iOS/iPadOS:

  • iOS → DTTG 3.7 (17332)
  • iPadOS → DTTG 3.6.5 (17316)

What is the original item you’re linking to?

The original item was a pdf that has been in my database for a long time.

I copied a link in DTTG (info, copy link) on my iPhone today and used that UUID instead in the one line get item shortcut. That item is a .jpg image and I get the same result: the shortcut fails to find the item on my iPhone and works on my iPad mini.

And does this persist after rebooting the device(s)?

When I first noticed the problem, I did restart my iPhone but it didn’t help.

I just restarted it one more time and my one liners still can’t find the PDF or jpg documents given their UUIDs.

I’m seeing no issue here. On DEVONthink To Go’s databases screen, select ? > Contact Us to start a support ticket.