Sleep Mode interrupting Database Sync -- Advice needed

I have a 3g email archive database that is now going on it’s third day of syncing.

It is slowing making progress, but the progress seems to stop when the computer goes into sleep mode (such as when I go to bed and leave it running, or otherwise am not using the computer) and sometimes when I am working on another program.

In Energy Saver System preferences, “computer sleep” was set to Never.

Any suggestions for optimal Energy Saver preferences or other ways to keep the sync moving along.

Using Devonthink Pro 2.7.3 on an Imac with OSX 10.9.2 and 20 g of memory.

Many thanks.

What kind of Sync is this and what’s your network situation? (BTW, having a lot of RAM has no appreciable affect on Sync if your network is sub-par).

Sleep mode, by definition, is going to interrupt the synchronization: the computer can’t sleep and pump out big chunks of data at the same time. You can blank the display if you want, but you’ll probably just want to keep the computer from auto-sleeping until the archive is uploaded. (I’m a little surprised that DTP is allowing the computer to sleep, actually.)

Relevant options are in the Apple -> System Preferences -> Energy Saver pane.


Takoma indicates that the sleep preference was set to “never”, and on an iMac there should be no confusion between “battery” and “power adapter” settings.

One way to have better control over sleep behaviour would be to use the program “Wimoweh”, which can be obtained for free, e.g. on In its menubar panel, one can, for example, choose DevonThink to prevent the computer from sleeping. So far, this has worked very well for me (e.g. for backups running through the night).

This app keeps your computer awake. Free, works great:

open up terminal and type:


Your computer won’t go to sleep until you end the process by pressing Ctrl c

There are more advanced options for caffienate too which are explained here


Thanks to all for explaining how sync and sleep interact and suggesting helpful solutions.

In my case, Devonthink Support helped me identify the underlying problem, which was a corrupted database on Dropbox. Cleaning the location appears to have fixed it.

Again, many thanks for a great product, a helpful company and a knowledgeable support forum.

Warm wishes,