Smart Folders do not show files which have an incoming link

I was scared to death when I saw that all my smart folders “lost” files. The smart folders in question are very simple - they are showing files which have a certain tag. I felt a little better when I saw that the files were not lost because I could see them when I selected the tag itself. After a little search I found out that only these files are not shown which contain an incoming link.
Why do smart folders react like this on files with incoming links? Any ideas how I could adjust the search for my Smart Folder or is this a bug?

Well, a screenshot of the smart group would be useful. In addition, please check that the the items (and their enclosing groups) are not excluded from searching, see Info inspector.

Welcome @damandy

In case you didn’t know: smart groups don’t contain anything. They only show items that match the criteria you specify. So if you delete a smart group, it has no effect on the actual items in the database.

And as requested, a screen capture of your smart group’s criteria would be helpful.

1 Like

Bildschirmfoto 2023-11-23 um 15.32.33
This is a screenshot of one of the smart folders - sorry it is in German and I am aware that smart folders do not “contain” files - sorry for the imprecise wording. Like I wrote before: The Smart Folder shows results but not all it should. It shows only files which do not have an incoming link. In the meantime I tried to delete the incoming link but the file is still not shown. When I create a new file with the respective tag it is shown.

Did you check the Exclude from search setting of the items and their enclosing groups? The item link is not the culprit in this case.

Yes, I did - please see screenshot.
Bildschirmfoto 2023-11-23 um 15.49.16

Did you just uncheck it or are you showing it wasn’t checked?

It was not checked all the time.

And the same setting of the enclosing groups?

Yes, also enclosing groups are unchecked. I even tried now to put in one of these folders a new file with this tag and this one is shown in the smart group :man_shrugging:t2:

  • Are these imported or indexed documents?

  • Have you done a File > Verify & Repair Database on the problematic database?

All files had been created by me within the database (formatted text files).
I have done Verify & Repair Database now - no effect.

Does reopening the database or relaunching the app make a difference?

I am very sorry but neither reopening the database nor relaunching the app (or the computer) helps.

Weird. Is it possible that there are multiple tags with this name in the database?

No, the tag exists only once in the database. I also tried to create a new Smart Folder and selected this tag again (same result). When I selected the tag also only one tag was shown.

Does the smart group show a duplicate of the file? Or a new file having the same tag & contents?

No, the Smart Folder just shows each file (with the respective tag) once (but only if they do not have an incoming link). Maybe another helpful information: If I delete the tag of a file which should be shown and then tag the file again with this tag - it is still NOT shown in the Smart Folder.

Are you able to reproduce this by duplicating the smart group(s) and the necessary files to a new database? Any chance that you could send us this database, e.g. exported via File > Export > Database Archive…?

Update from my side. What solved the problem is that I moved one of the files in question to another database. When I moved it back afterwards to the place before, the Smart Folder is showing it now. On the one side I am very happy that we found a solution on the other side I still wonder what the problem was. Anyway, thank you so much for your patience and good advice. Excellent service.