Smart group not working as expected when 'begins with' is used

I am getting inconsistent behavior in my smart groups when I do a search for “matches” a term and “begins with” a term. When I use the former, I can see a list of the items in the smart group in both the sidebar and the listview. When I use the latter, I can only see the items in the smart group in the list view.

I search for “matches” name1 in tags named name1.thing, etc.:

I can see the results in both the sidebar and the listview:

Now I change the search to use ‘begins with’ name1, which should match the same groups:

I see the same items in the listview, but can no longer see the items in the sidebar:

There is no arrow next to the smart group in the sidebar that I use to see the contents. Why is this? Is there any way to arrange the search so that I can use ‘begins with’ and still see the items in the sidebar? I want exclude items that don’t start with my terms, but I can’t seem to do that without giving up the sidebar view, and I typically use ‘show only documents’ in the listview. The smart group is clearly finding the same groups because they show up in the listview.

Thanks in advance.

Oddly, when I add a random additional search for any document, I get the behavior I expect when using begins with, in that I am able to see the matched groups in the sidebar:

I now see the groups I expect within the smartgroup in the sidebar as well as the listview:

However, I have to add search terms I don’t want. I’ve tried other search terms and it doesn’t work. It seems to need something added using OR/Any.

What are your General > Interface settings?

I was able to reproduce the issue, the next maintenance release will fix this.

Thank you so much! I’m glad I’m not crazy. I’ve been banging my head against a wall for hours tonight trying to figure out what was going on. It’s happening for me during search as well. If I select a group and begin typing the name of a record I know exists (e.g. cover.jpg), it will match all the way up to “cover.” but as soon as I type “j” (the first letter of the file extension), the result disappears. It happens in one of my databases, but not the other.