SnapScan Integration Not Working


I have just upgraded from DevonThink Pro to DevonThink Office Pro specifically to be able to directly scan from a SnapScan S1500M.

I have installed the version 2.4 DevonThink Office Pro, and put in my new upgrade license key. I then downloaded and installed the latest version of SnapScan (version 32 L60). This scans fine to a file.

I am running Mountain Lion on my Mac. It is a fresh clean install. SnapScan Manager was not previously installed, only DevonThink Pro, as described above. My existing DTP databases open fine and work ok.

Now whenever I open DTOP it pops up with a message:

“SnapScan Manager support is installed but DEVONthink Pro Office is not the default application, would you like to fix this?”

I click on the “Fix” button and it warns me about disabling the ‘Quick Menu’ that I have already done.

The above loop repeats itself and I cant scan direct to DTPO—it continues to scan to a file as configured in SnapScan Manager.

I have opened SnapScan Manager and looked at the ‘Profiles’. Under the Application list there is no entry for DevonThink. I am assuming the ‘fix’ is not being applied for some reason, hence the above loop.

Please can you tell me how to make this work, and stop the above ‘fix’ loop above?

I have also run Mac OS X DiskUtils repair file permissions also—but that made no difference.



Is it a typo “I have installed the version 2.2 DevonThink Office Pro…”, current version is 2.4 (just released, but the previous 2.3.x has been around for a while). Otherwise your procedure looks alright.

Thanks for spotting that—it is a typo! I am running the latest DevonThink Office Pro 2.4 as you suggested.

As an update on my original post, I have tried the same upgrade on a different Mac which now also has the same ‘fix loop’ on it. However this other Mac is running Lion (Mac OS X 10.7.4) and using SnapScan Manager version 3.2 L20.

I guess the issue/bug must be to do with DevonThink Office Pro 2.4? Hopefully a workaround or fix can be provided soon.



I’m also running latest ScanSnap, DPO 2.4 and Mountain Lion and it works fine. Lets se if our configurations agree. Opening settings in ScanSnap I have;
Use Quick Menu un-checked
Profile: Standard
In the TABs;
Application: Application selected Devonthink Pro (selected in the rollbar)
Save: To a folder in me home directory and I selected the yyyy_MM_dd_HH_mm_ss file format
Scanning: set to Best, Auto color, and Simplex
Scanning: File format PDF, all the rest un-checked

In DPO Preferences, OCR, I have checked “Convert to searchable PDF” and set resolution to “Same as scan” and selected my primary language. That’s all.

Really hopes you can get it to work, great combination.


Thanks for trying to help me out!

SnapScan Manager settings are basically the same as yours, except:

Application: no option/entry for DevonThink available (guess this is why it loops as this is not being installed by DevonThink?)
Scanning: Auto, Auto, Duplex
File Option: same as you

In DTOP OCR preferences I have the following set:

Convert to searchable PDF: ticked
Move to Trash: unticked
Searchable PDF (enter metadata option): ticked
dpi: 150
same as scan: unticked
quality: 75%
recognition: automatic
primary language: english

I think the main issue is that it is not installing the application entry in the SnapScan Manager application menu. Every time I start DTOP it offers to set this up, but fails—hence it not working.

I’m sorry to hear this.
Apart from searching the System Log for clues, I throw in a wild one. Maybe sandboxing in ML is doing something. Can you try System Preferences->Security & Privacy->General and click the last radio button “Anywhere”.
Restart DPO and click the “auto” install button.

Next, searching the System Log for ideas may be a good thing.

Thanks for the suggestions again. I have now also tried/checked:

Sandboxing is disabled by setting it to ‘Anywhere’ in System Preferences–>Security & Privacy.

I have just run the Mac OS X Console app and gone through the loop again of starting up DTOP and pressing the ‘fix’ button to install support for SnapScan Manager. Nothing comes up in any of the log files.

I moved the folder in ‘~/Library/Application Support/DEVONthink Pro 2’ and all the DevonThink preferences files in ‘~/Library/Preferences’, then restarted DTOP. This made no difference either, so put the original files back again!

Guess I will have to wait until someone in DevonTechnology Support gets back to me. I have opened a ticket up for the issue also.

OK, again sorry to hear this. Hope someone at Devonthink can help.

Me again. One more idea. Have you tried setting DEVONthink as the Application directly in ScanSnap Manager?
If not, quit DPO. Start Scansnap Manager and go into settings, first tab “Applications”. Click on the “Add or Remove” button. In the new window click “Add…”. In the next window click “Browse…” and select DPO as the application. Give it a name and close all windows, except the ScanSnap Manager window. Now you should be able to select your new, added, application in the rollbar. Start DPO and this time you should be able to get through and DPO “update” of ScanSnap should be accepted (and never return).
Good luck!

This is now resolved. In case it helps someone else, below is how it was fixed:

DevonThink support contacted me, and asked me to downgrade to version 2.3.5

I installed that older 2.3.5 version (over the top of version 2.4 - replacing the application file). When it ran for the first time it correctly integrated with SnapScan Manager, and allowed me to scan directly to DTPO as expected.

I then used the in application software update to go back up to version 2.4 which is the current version. Once upgraded, the SnapScan Manager integration continues to work properly.

I guess the issues must be caused by the 2.4 version installer…

Edit: It did work. Sorry… Downgrading to 2.3.5 fixed the issue for me too.

Scansnap scans and sends single sided PDFs to Devonthink Pro but if the document is two-sided it doesn’t make it into my DTPO inbox. A copy of the scan goes to another folder on my hard drive but the PDF just doesn’t make it to DT.

I downloaded the latest 2.4.1 version - didn’t work
I downloaded the 2.3.5 version - didn’t work
Restarted my iMac - didn’t work
OCR options - Target Pages: All pages
Scanning side: Duplex Scan
Deleted DTPO from the ScanSnap application then added it back.

So, why is a one-sided document making it to DTPO but not a two-sided?

I can find the legacy version of DTP 2.3.5, but not DTP Office. Anyone have any help on locating the 2.3.5 version of DTP Office?

I have the same problem. Loops on install. I did find that manually creating a profile and manually associating the app to that profile in ScanSnap Manager stops the loop, but looks like DTP Office still never recognizes the scanner, as evidenced by “Devices(0)” in the scanning dialog after File > Import > From Scanner or Camera… Is the 2.35 version generally available, or do we need to contact support to get that version? Note: I am trying the software - have not purchased yet.

Simon T

You can pick up 2.3.5 here: Legacy Downloads.

Thanks, Bluefrog, but the legacy downloads page only has DEVONthink Pro, which does not (after I followed the procedure of installing/overlaying) seem to have the scanning integration. So, I’m either confused by the recommended work-around here, or need a different version not available on the legacy downloads page :neutral_face:

Simon T

For those having difficulty setting up communication from ScanSnap Manager to DEVONthink Pro Ofice under Mountain Lion, the solution is to quit DEVONthink Pro Office. IN the Finder, select the DEVONthink Pro Office application file and open its Info panel. Click the option to change to 32-bit mode. Launch the application and set ScanSnap Manager’s Application setting to DEVONthink Pro Office. Now you should be able to send scanner output to your database(s). Once that’s working, you can then switch DEVONthink Pro Office back to 64-bit mode if your Mac and OS X version allows that.

As for the “loop” reported by the OP, if you experience that, when the message offering to set DEVONthink Pro Office appears, click on the option not to display it again, then hit “Cancel”. The issue will go away.

DTPO was closed, turned on the 32-bit mode. SS still will not send a duplex scan to DTPO. I have also tried deleting the DTPO from the ScanSnap settings and re-selecting which also doesn’t work.

Any other ideas?

Have you contacted Fujitsu Support about the matter?

Bluefrog thanks! Looking at the ScanSnap Manager as the problem and not DTPO helped me solve this.

I finally figured out it was a problem with the ScanSnap software as I couldn’t get my S1300 to send scans to Evernote either.

This is how I fixed it:
Open ScanSnap Manager
Pull down the “Tools” menu item
Select “ScanSnap Support Tool”
Choose “Restore” from the list

I had to manually reenter DTPO as a profile though I think DTPO would have sent the correct info to the ScanSnap Manager had I not already done it myself.


Glad it’s back up and working, Paul! 8^)