Snow Leopard Issues

I know you are working on 10.6 compatibility already so maybe you know about these issues, but there are a few things I have noticed with DTPO since I installed the OS upgrade:

OCR Activity window is pretty messed up. I generally have several scans waiting in the queue and what shows up now is an occasional status bar with no title, then several inches of white space before the next nameless bar. Also I had about 15 items that should have been showing up but no more than 2 at a time are showing up now, sometimes 0.

View panes showing previews of the documents are inconsistent now, sometimes they show nothing, sometimes some panes work and not others.

The program unexpectedly quit when I closed a file I had popped out into its own window. :frowning: New groups I created while scanning are still there, but most of the files scanned today have disappeared. It also doesn’t appear to be aware it quit, no notice showed up until I restarted it and it said the database was already open.

I have no suggestions to offer; rather my own 10.6 experience.

As a legal user of 10.6 betas I have been using 10.6 full-time for a number of weeks (since the release of 10A432, which is what is shipping to customers now). I use DTPO regularly for several things during the day, including scanning documents. I just scanned six double-sided pages from an insurance outfit and everything worked without a hitch. I’m using a Scansnap scanner.

As for other things I haven’t seen anything like you’re describing above using the current build of 10.6 and DTPO 2.0pb6. They both work together quite well.

You might want to open a support ticket and include DTPO info from the console so that your specific problems can best be diagnosed and resolved.

I work in insurance and use a ScanSnap as well. And the first 50 or so documents I scanned today were fine too, it wasn’t until after that that I saw the problems. The volume I do is pretty high, at least a thousand pages a day. I’ve never had any problems with DTPO in previous OS versions on any of the computers I use (an iBook, Intel iMac, and MacBook Pro) and didn’t have anything else running and hadn’t made any changes other than upgrading the OS. The issue I mentioned that I can’t say for sure was affected dependent on the number of scans done was the view panes, as I wasn’t paying much attention to them right away. Anyway, I don’t mind using 10.5 for a while longer, DTPO performance there has always been great and I don’t want to risk the inconsistence… it is still a new release of course so I will wait to see if anyone else is having similar issues.

Wow! For your sanity I really hope this problem is quickly and effectively resolved. I can’t imaging scanning that many in a month, let alone a day.

Best of luck with this one!

After installing Snow Leopard, I have issues with OCR too. First, DTPO hung during OCR activity (analyzing the 9th page of a PDF sent via ScanSnap), then after Force Quit, DTPO is fine, but refuses to initiate any OCR activity.

Should the OCR be reinstalled somehow? I suppose it has been tested to work with Snow Leopard, so perhaps the process of upgrading affected things?

Other than the fact that the OCR Activity panel was hosed I didn’t seem to have problems with it. Currently, it purrs with my latest fixes.

For those of you using a ScanSnap are you scanning to file or right into DT using the Office version? Fujitsu has said scanning to file does not work.

Scanning to DT Office - the Scansnap works fine. The files are saved - it’s the import via OCR that fails to work a it did before Snow Leopard.
I just tried again, and initially it seemed to work. But when I queued a second file in DT’s OCR, it did not register the second one. Perhaps that’s the problem?

The reason I ask is I don’t use the Office version and just scan to PDF outside of DT then import. I’m hearing that the function of that scanning to file (PDF or otherwise) is something broken in SL.
So here’s a question from a non-Office user. Can you scan using the ScanSnap to the DT global inbox? Or do you have to scan to an open DT db?

*Edit. I think this might be a moot point because it will still have to be scanned as a file which is the main problem.

DevonThink Pro mail conduit is forcibly disabled in Snow Leopard 10.6 build 10A432:

Update: OCR actually works, but the OCR activity window does not display what is going on correctly. It does not list the files in queue, sometimes part of the progress bar is visible.

Update 2: Just read a general email from Devontechnologies that indeed the OCR activity window’s performance is affected by SL. The next update to DT will apparently fix this.

This problem is definitely still present in the release version of Snow Leopard. I just installed SL last night on my MacBook Pro which had been running Mac OS X 10.5.8 and I got that identical message during the install.

Since I use this functionality a LOT in DTP, is there any ETA for a fix?

In the next, soon-to-be-released update:

The Balcony » Again: Snow Leopard and DEVONthink

Well I’m glad to see I’m not the only one having these problems, but sorry that it means more work for everyone. I have been scanning to a searchable PDF directly into DT. ScanSnap is still showing some issues with their software on their site too, but it looks like they are working on it. Just make sure to check with them too even when DT is patched if any of those issues affect you. … lletin.pdf

twicks: Lol… thank you but don’t worry about me, I went insane from the scanning months ago. I’m making a 35 year old office paperless. Owned by a guy who prints his emails. It’s a long process but will be worth it at the end.

i recently upgraded to Snow Leopard, and i’m not sure i’m posting in the right place…

anyhow, since upgrading to SL, i had to re install DTpro, and also install the OCR engine.

i thoguht that was done, but when I doupble cheked the help addins, i see that the OCR was uncheced.

I tried to install, and it crashed - then I tried again, and it downloads the file again from teh website. then i get a message that file already exists and to go to ‘install addons’ on the help menu, where it goes on and downloads the file again!!

I’ve tried both options, my mac only and intel macs…


MacBook Pro

That means that the OCR engine is installed.

Just disable the “Global inbox in save dialogs” option.

thanks for VERY quick response…

I upgraded to Snow Leopard a few days ago and so far have experienced nothing but problems so I do not think this is related to Devonthink itself.

Can I ask those who are on Snow Leopard how is it working for you? I read the Apple forums and it’s this thousand message long stream of angst so I know I’m not alone but since upgrading my Mail crashes constantly, the finder is slower then I can ever remember it being, everything I start looks like it has some kind of brand new problem to go with the supposed performance increase which I’m just not seeing.

Right there was a reason I was posting here, Devonthink crashes constantly, but that’s far from the only problem I have right now so I think I’m going to go ahead and reinstall and wipe everything away, that’s what I wanted to do but the installer makes it almost impossible, there is no option to do that anymore, I have to go start disk utility and then clear the disk and then go back to the installer, I do remember that in leopard it was one button, now Apple has hidden the process of clean installation behind having to launch disk utility first. Fine I can understand they want people to upgrade their systems instead of use migration assistant, but before that’s a possibility then the system needs to work. I have a folder full of programs that are supposedly incompatible with Snow Leopard so I’d think it was smart enough to figure out what might be wrong but so far this has been one big headache with no end in sight except starting over from my last Leopard time machine backup and clean installing.

Back in another day to let you know how it all went.


You’ve posted here before, so perhaps other messages have given this information, but it would be really helpful to know what model Mac, how much RAM, what speed processor, etc.

It’s working very well. It’s very fast and really nice to use with the new features. I’ve had a few issues, but nothing that can’t be dealt with.

With any major software upgrade, the ones who are having trouble are the ones who make the noise. You never hear from the thousands of users who are not having problems. Thus the problems look much larger and more prevalent than they really are.

Before you upgraded, did you do an extensive compatibility check of your software? I spent two or three weeks before SL was released checking, getting as many software updates as possible that were SL compatible when they appeared. Software that wasn’t updated and I knew would cause trouble (AppleJack is one example) I uninstalled, so I wouldn’t try to use it and get into trouble. (There’s another utility I was going to use in my example, but the clueless censor in this system kept changing its name to something else, so I couldn’t make my point.)

I’ve had some Mail crashes, I’m still tracking down the causes (and sending the notes to Apple each time they happen), but the Finder is faster than it’s ever been.

How much RAM do you have? The more the merrier with SL.

You’ll have to be a lot more specific about when it crashes, what you’re doing at the time and your configuration before the rest of us can offer any kind of meaningful suggestions.

I can’t offer much reply to all of that except to say that everyone’s setup is different, and very many of us are having very little problem, considering the mass of changes that are present in this update. It was probably a week old when I installed it, so I’d heard a lot of the wailing and gnashing of teeth by the time I did the install. It was worth the wait, everything I read before doing the install was helpful, a little research goes a long way.

I’m running snow leopard, no major issues to speak of, did the clean install and used migration assist. I haven’t installed devonthink yet, waiting on the snow leopard version to get released, still have a ways to go with putting everything back to where it belongs and reinstalling Adobe CS4.