[solved] "DEVONthink.mailbundle" is no longer available on macOS Big Sur

In Apple Mail 14.0 of macOS Big Sur, “DEVONthink.mail bundle” of DEVONthink 3 is

“DEVONthink.mailbundle” cannot be opened because the developer cannot be verified

Is displayed and can no longer be used

Welcome @yoidoreo

Please update your software to DEVONthink 3.6. A Big Sur compatible Apple Mail plugin is included in it. Thanks for your patience and understanding.

1 Like

Unfortunately, the Big Sur version of the plugin is no longer working, either.

Which version of DEVONthink and of Big Sur do you use?

Big Sur 11.0.1 and DevonThink 3.6

What’s the build number of Big Sur? Unfortunately there seem to be different versions of Big Sur 11.0.1.

The exact build is Big Sur 11.0.1 (20B29).

That’s bizarre - under exactly the same circumstances (DT 3.6, Big Sur 11.0.1 20B29) that plugin works for me.

Have you tried restarting the Mac and then trying again to activate the plugin, or removing and reinstalling the plugin, or shouting at it? :flushed:

I think I might be tempted to delete the plugin in /Users/yourusername/Library/Application Support/Mail/Plug-ins/Bundles/Users/yourusername/Library/Mail/Bundles after closing both Mail and DT, then restart my Mac, and reinstall the plugin from DT (assuming DT realises it has gone, which I guess it would). I haven’t tried this, though, and I can’t promise it won’t distort the delicate balance of the planet.


Thank you, that did the trick. Deleting, not shouting, though I can recommend a good shout every now and then. Even more bizarre was that I had to boot into Recovery Mode to delete it. In regular user mode, I was neither able to read the file permissions nor delete it. Even with a root command sudo rm -rf I was denied with “Operation not permitted”.

For future folks running into this issue:
My only possible explanation is that I had temporarily disabled SIP over the weekend for a day or so, trying to get something else to work (I was trying to get Steam Input to install in Big Sur, unsuccessfully). I didn’t go anywhere near the Mail plugin but perhaps it got mangled in the process anyway.


I have deleted the old plug-in and the new Big Sur plug-in is installed and working.

However, whenever I start Mail I still get an error message saying the old plug-in is incompatible. Mail shows the plug-in in the Manage Plug-ins pane - but it is unchecked.

What else do I need to delete to get Mail to stop seeing the old plug-in?

Thanks in advance.

The old plug-in which was removed? A screenshot might help.

My apologizes.

The top image is of the Mail Bundles directory showing the two plug-ins that are currently active in Mail.

The middle image is the error message I get every time I open Mail.

The bottom image is the Manage Plug-Ins pane in Mail showing the old plug-in though unselected, along with the two Plug-ins that are as they should be.

Thank you for taking the time to help.

You could reveal the DEVONthink.mailbundle via the contextual menu. In which folder is it located?

That’s the problem…that mailbundle doesn’t exist. I’ve used Houdahspot and searched the whole hard drive and it doesn’t exist. In the mail preferences, in the panel that shows the three plug-ins and where it thinks they are…that’s why I posted the picture of the directory with two mailbundles. That’s where Mail thinks DEVONTHINK.mailbundle is…but it’s not there.

That’s why this is is so confusing. Thanks for any suggestions you might have.

And the contextual menu of this panel doesn’t even offer a possibility to reveal this plug-in? Or does reveal just not work?

That’s it exactly. When I choose “Reveal in Finder” nothing happens because the file doesn’t exist. Yet Mail for some reason thinks it still does.

In that case I would suggest to reboot the computer and if this won’t help, to delete Mail’s preferences.

OK… your suggestion wasn’t what fixed it… but in trying to find the Mail preferences to delete, I found the DEVONthink.mailbundle under /library/application support/mail etc etc. I was not able to delete that folder because it was protected, so I had to turn SIP off and then I was able to delete it. Problem solved!

Thanks for your help. I appreciate it. I’m going to have to search to see why Houdahspot was not returning that folder when I searched for it but it returned the others for DEVONthink.

HoudahSpot uses Spotlight’s index and therefore inherits its limitations. For searching in any folder or even for invisible files/folders you could also try EasyFind or FindAnyFile.

Thank you! You’ve been very helpful.

1 Like