[Solved] DT freezes when opening scanner


long time DT user here. Loving it. Since the last update, DT3 Pro (3.8.6) freezes when I open the scan dialog via Import → Devices → Canon MB5300.

Using the Image Capture App (“Digitale Bilder”) of MacOS connects fine and works like a charm.

I am running MacOS Monterey (12.3.1) on an M1 Macbook Pro.

Anyone has an idea?

Does it work after updating to the latest version of Monterey? In addition, the Import sidebar also supports email archiving, which email clients do you use or are installed on your system? This might also be the culprit.


Just updated.Strangely it froze even earlier (when opening the Import pane). Thanks for pointing me towards the Mail plugin. I am using Airmail but have also Apple Mail installed. In Apple Mail I checked permissions and found the plugin to be deactivated and in need of permissions. Once I granted these, the import pane worked as usual.
Thank you.

1 Like

Thanks for the kind words. They’re appreciated!

Note: The current version of macOS Monterey is 12.6. We advocate staying current with the operating system and our point releases.

1 Like