SOLVED: Problem on Ventura

I just upgraded to Ventura… when using DT, I now have a problem that after searching, and clicking on the search result in the list, the doc tries to loads, then the search result for that file just vanishes.

When I search again using the same keyword, the doc doesn’t appear in the search results.

Anyone else had this issue? - Feeling nervous about where the docs are going as well.

DEVONthink after upgrade to macOS 13.0 working fine here.

Do you do any sort of syncing, and if so, what kind? Have you tried a Verify/repair on the database? Do you have DEVONthink 3.8.6 (latest)?

Argh - I’ve just worked it out… Mac OS has changed the name of a folder that the files are referenced from so DT has lost all its links. [For a good reason] I’ve indexed a sub-folder of Mail in DT to capture all the PDFs that come into a mail folder - they then get indexed automatically.

Mail has now moved its mail folder from ~/Library/Mail/V9 to V10… so all the indexed files have lost their reference.

Is there any way to update all links with this change in the database? or do I have to re-index the whole folder?

1 Like

Select the enclosing indexed group in DEVONthink, then use the Path popup in the Info > General inspector to select the moved path.

1 Like

Brilliant - thanks I’ll let that run and see how it goes

Took a while, but worked perfectly - thanks so much

1 Like

Indexing the Apple Mail directory in the User Library is technically possible but we don’t advocate it.
Using the Apple Mail plugin to import emails or archive mailboxes is the suggested method.

Yes, but the suggested method is a Pro feature. Non Pro user index their mail library :crazy_face:

It is still not advocated and there are big problems with your suggestion…

  • Emails are not indexed in the Standard edition, regardless if they’re indexed or imported. So you can’t find them via a toolbar search for contents.
  • Subject lines are not indexed, so you can only search for emails via the number assigned to the .emlx file, e.g., 153.emlx.
  • No properties are available, e.g., who sent or received the emails.
  • Emails are not searchable via the Search inspector.

This was just a joke and not a recommendation.

1 Like

Recommendation: get the Pro version. No joke :wink:

1 Like

Understood :slight_smile:

However, for those inclined to indexing the Mail directory - especially those running Standard, those are definitely things to be aware of.

1 Like