Some weird behavior with RTF documents


I have been using DEVONthink for the last year or so as an aid to managing notes and materials related to my dissertation. In that time, I’ve amassed quite a large database (200+ megs) and DEVONthink has performed without a hitch. I want first off to thank you for this excellent product because I really don’t know where I’d be without it. Actually, I do know but I prefer not to think about it. Anyway…

I frequently will create RTF documents in Word that I then import into DEVONthink. So far this has gone without a hitch. But a document I created the other day has started some weird behavior. On opening the document in DEVONthink, I discover that a strip of text on the right-hand side of the document has disappeared. I can’t re-adjust the margins in the document to reveal them and I can’t select that section of the document. However, if I put my cursor on a line and hit left arrow the cursor disappears into the space, reappearing as normal on the line below after traversing the dozen or so characters that fit into that space. I tried to change the alignment of the text to see if shifting it all over to the left hand would change anything, even though it was already flush left, but it didn’t. That is at least until the fourth time I did it. Then suddenly it was all flush left as normal. All the text was there. But I still couldn’t get the margin to move past 7.12 inches.

Frankly, I am at a loss to understand what is happening. Any help would be appreciated.

The RTF files created by Microsoft Word aren’t perfect and make the Apple RTF library choke. I would think this is what’s happening here. You can verify this my open the same problematic RTF document in TextEdit. If this shows the same strange behaviour, it’s the RTF. If it doesn’t, then is probably DEVONthink.

Suggestion: Try to save the file in Word as a Word document and import this.




I actually tried opening the document in Textedit to see what would happen for exactly those reasons. It opened without any problems. I also saved the document as an RTF via Textedit, imported it into DEVONthink, and had the same problems as I described before.  :’(

Strange. Could you send us the RTF so we try it ourselves (if it’s not confidential of some kind)? You’ll find my e-mail address to the left when you click the little envelope icon.