"Sortable Document Date” as as a separate field

Hi everyone, I would like to automatically add the information “Sortable Document Date”, which I can use when renaming the document, to each document as a separate field.

The goal is to be able to select documents created from DATE X to Date Y. Not in Devonthink, but by the creator of the document.

So Devonthink recognizes the document date, but I can’t find a field where it is placed. How do I get one?


Date 2020-03-24 should appear in a field?

Thanks! :slight_smile:

You could use a user meta data field and copy the sortable date into it from your smart rule.
Although I do not quite understand what you mean by

The “creator of the document” is presumably the company that send you this document. Why and how would they want to sort their documents in your DT by date? Or do you mean a person (who probably wouldn’t be the creator)? But then: What does “not in Devonthink” mean? Where?

Smart rule was also my first thought. So I activated the custom field Date:
CleanShot 2020-09-07 at 14.08.28
After that I tried to build a rule:
CleanShot 2020-09-07 at 14.09.40
Unfortunately, “Sortable Document Date” does not appear here.
I can’t find anything else in the selection that refers to the date in the document. All date fields rather reference metadata in Devonthink e.g. created. Or do I get something wrong?

It’s the document date, the Sortable Document Date is just a special placeholder for renaming.

This is exactly what I am looking for. But where do I see the document date directly in the info mask? Devonthink seems to know this one. Do I have to create a custom field here?

When I move, the rename function can enter this information, but when I use this smart rule, nothing happens.


I would expect Devonthink to show the document date in these two red fields. Am I wrong? If this is not intended, then I would only have to refresh the information that is already collected in the custom “Datum” field.

The smart rule should work after removing the Cancel/Abbrechen action.

Unfortunately I can’t see any Cancel action. Am I blind?
CleanShot 2020-09-07 at 15.01.57

edit: in the first screenshot there was one. But not anymore. Still not working :frowning:

There was still one on the first screenshot. But this smart rule is only applied on demand, you should probably define a trigger (e.g. to execute the actions on import).

As long i use “execute the actions on import” it works. Manuell it doesn’t. Is this a bug?

Thank you! :slight_smile:

How did you execute it manually?

Mark the corresponding document and then right-click to select the Rule.

Applying rules that way uses only those items from the selection which match the conditions. As the rule doesn’t have any, nothing’s executed. Therefore the rule should include at least the condition Kind is Any Content.

Or you drag & drop the selection onto the rule, in this case the actions are always performed.

Okay, I don’t understand this. How would it look like if you want to apply the filter to everything that is moved into this database? I thought then “All” would be enough? Thanks!

“Alle” is just a setting for the following conditions but there are none. But if the rule should be automatically applied, then you’ll need a trigger like on import.

ok, thanks for that explanation and thanks everyone for your help! Seems working now! :slight_smile: