Sorter Bug - DT3 3.6.1 with Bartender 4 - and a Temporary Fix

I have upgraded to Big Sur and noted that one of the changes is that there is increased spacing between Menu Bar items. That means if you are a pathological curator of menu bar icons as I am, you can run out of room in your menu bar.

Bartender 4 is a Beta application which addresses this issue in Big Sur. It works really well - except that in some situations the DT3 Sorter does not appear unless you toggle the sorter off and on in Preferences.

I worked through this issue with the Developer of Bartender – Ben Surtee – who was very helpful and helped me to discover that DT3 is initially setting the Sorter to Not Visible. Hopefully DevonTech @cgrunenberg can help with this long-term.

For now, one workaround is is to simply toggle the sorter off and on when you observe the problem.

In order to fix the issue for the future after you have toggled the menu bar off and on, you can override the default Preferences as follows via Terminal:

defaults delete com.devon-technologies.think3 "NSStatusItem Visible Item-1"

Ben says he is available via Bartender Support (send Feedback through the app) if there are additional questions.

Thanks. We’ll have a look at this.

1 Like

I have just tested DT 3.6.1 with Bartender 4 on both intel and Apple Silicon devices and it works correctly without any changes to the defaults. The Sorter has two menu items, one of which should be hidden, I believe this what Ben Surtee is referring to.

Thank you - any ideas why the problem was noted on my computer and reproduced by Ben Surtee and fixed with his suggested temporary solution?

Note the issue seems to occur particularly (maybe exclusively) when the menu bar has enough icons such that it overflows in the absence of Bartender; did you try it with such a setup?

Okay thought I would come on here to say what I found. Without Bartender (as it doesn’t really have anything to do with the bug that I think I found), all tested on macOS Big Sur.
In DEVONthink set the Appearance from “Show as Menu Extra” to “None” then set it back to “Show as Menu Extra”.
Two things have now happened, the menu bar item with autoID Item-1 is now set to not be visible, and the show menu bar item has now changed from ID “Item-1” to “Item-2” as I am guessing DEVONthink created a new NSStatusItem for it.
This has two consequences, the position of the DEVONthink menu bar item changes as its position is stored by its ID (until restarting DEVONthink when the position will be Item1’s position again, but it wont be visible because of the second consequences), and its just moved up 1. Then and more serious, when you restart DEVONthink the menu bar item will be hidden as its now back to ID “Item-1” and this has been set to not be visible.
The only way now to get DEVONthink to show again is to go to Preferences at set the Appearance from “Show as Menu Extra” to “None” then set it back to “Show as Menu Extra”. Or if you want it to show when you launch DEVONthink you need to run the below terminal command:

defaults delete com.devon-technologies.think3 “NSStatusItem Visible Item-1”

The solutions to what I believe is the issue, is to not create a new NSStatusItem when you set it back to “Show as Menu Extra” if one exists, and instead set its visibility back to true.

Let me know if I can help anymore with this. Or you cannot recreate the issue.


Thanks for the detailed information, I can now reproduce the issue and will update the Sorter.


This bug isn’t unique to Big Sur, I am on Catalina and see this frequently. I didn’t ever think it was anything to do with Bartender (which I use and love). I’ve always just dealt with it by toggling the sorter, I didn’t notice it for the longest time as I had been using Dock Tab mode…but it got annoying as it interacted with a few apps I use rather poorly and thus switched to the Menu Extra.

I’m glad I am not alone in seeing this, but I really wish we could get a permanent fix. I had seen this thread but didn’t read it, but I just went to use the sorter and it wasn’t working so I came back :slight_smile:

I will check it on Catalina too.

I have added a fix for this and it will be included in the next update