Sorter is still broken (2.3)

With the 2.3 release of DTP, the sorter still has some issues:

  1. When I drag the sorter around the edges of my screen, bottom to sides, it’s now often disappearing from my screen, so that I have to go into the preferences, quit the sorter and restart it. Once, instead of disappearing completely, the sorter tab was reduced to a think line that I could click on (with some effort) to bring it back (perhaps it’s always doing this, but sometimes I’m just not seeing the line).

  2. As always, I have my dock on the right side of my screen, and the 2.3 sorter still sits on the edge of the dock instead of the edge of the screen when I drag it to that side. BUT NOW, if I expand the sorter and then un-expand it, it goes flush to the edge of the screen. It stays there until I expand it again, at which time, it expands from the edge of the dock, but will then shrink down to the edge of the screen. If I hide and then re-show the dock itself, it will also push the sorter out form the edge of the screen. It seems like you’re so close to getting the sorter to work on the same side as the dock! Don’t give up now. :slight_smile:


Hi Doug

Thanks for the feedback. Are you running on Lion or Snow Leopard? Interestingly you are getting different results to me :slight_smile: I will take a look to see what could be causing that.

I’m running Lion. Thanks for looking into it.


I have a broken Sorter as well in Lion 10.7.1 w/ DTPO 2.3. Sorter was misbehaving, not letting me take off a database inbox (not the global one) and then not opening at all, just going light-grey when I clicked on it. Then I dragged the sorter around a corner of the screen and now when I launch it, it comes up only with a single faint black line, no “DevonThink” sorter tab.

I dumped the files inside ~/Application Support/DevonThink Sorter. Still no go.

update: I got a hold of that black line and finally was able to drag it around the corner to the left side of my screen again and it turned back into the grey “DevonThink” sorter tab. It still does not open, however.


Hi Jeremy

Removing the ~/Application Support/DevonThink Sorter files will reset the sorter, to reset its positioning information delete the file ~/Library/Preferences/com.devon-technologies.think-sorter.plist

That should reset your position to its default.

Thanks, Alan.

I deleted both files again, and I now get this pop-up:

“The location of the document
‘Default.sorter’ cannot be determined.
You can specify where to save it.”
[Cancel] [Save As…]

Where should it be saved?

I saved the file “Default” to the desktop, then deleted the file. It looks like Sorter crated its own “Default.sorter” file in ~/Library/Application Support/Devonthink Sorter. Now the sorter seems to be working. Shall I do anything else?

And another, probably unrelated issue: my global inbox is empty and but has a -1 by it, meaning that it thinks there are -1 items in it… is this related? What do you think about it?

Hi Jeremy

The “Default.sorter” file should be in ~/Library/Application Support/Devonthink Sorter so that is right.

Having -1 in the global inbox is a bit strange.If you add a document to the global in box via the sorter does that number change to 0 or 1 or reman at -1?\


Emptying the trash will reportedly solve the negative value problem:
[url]Confused item counter for inbox]

Tom S.

Thanks, Tom. Emptying the trash worked like a charm.

Alan, FYI, the number did change, it was always one less than the number of items in the global inbox.

Thanks again, Jeremy