Sorter Problem. How to get files out of Sorter?

I am struggling with DevonThink Office Pro’s Sorter. I have about 300 items in the sorter, however when I open it, I get the following message “xyz.pdf couldn’t be copied to “Global Inbox” because an item with the same name already exists. Investigate the problem using the Finder.” Problem is, I cannot even find said file on my computer through Finder. None of the other files that I subsequently added to the sorter prior to knowing that there was a problem are transferring to the inbox. How do I clear out the sorter without losing the files I have there? I don’t know if I still have the files that are in there.


If you are using Lion or Mountain Lion, Apple has hidden your User Library.

In the left column of a Finder window, click on your user account name. In the Finder, click on the Go menu and choose “Go to Folder”. In the query box, type (if not already present) “~/Library/” (without quotes) and press Return. Now you should be able to see and navigate the contents of your User Library.

Inspect the contents of the folder named Global Inbox at ~/Library/Application Support/DEVONthink Sorter/. You can “rescue” the files contained there by dragging them to a new folder in the Finder, or by dragging them to the Inbox folder in the left column of the Finder window.

Now try dragging a test file (perhaps a copy of an existing file in the Finder) into the Sorter tab’s Inbox location. Was the file immediately sent to the Global Inbox database when DEVONthink is open?

If so, the Sorter is working again, and you can try filing the files you had removed from the folder within the Sorter folder (EXCEPT for that possibly damaged PDF file).

If not, Quit the DEVONthink application. Delete that DEVONthink Sorter folder at ~/Library/Application Support/. Relaunch the DEVONthink application. Does the Sorter now appear and work properly?

I was unable to see any files in my Global Inbox when using the Sorter.

I am a new user. I had a previous version of DevonThink Pro which I deleted using App Zapper before I installed DevonThink Pro Office yesterday.

After installing DevonThink Pro Office, I tried dragging a file from the desktop into the sorter. I inspected the contents of the Global Inbox as you suggested. I saw that there was a folder of Medical pdfs that were still in the Sorter from the previous version of DTP. So, I moved that folder to the trash and emptied the trash.

Then I tried creating a new “note” using the Sorter and I didn’t see it when I looked in DTP, nor did I see it in the contents of the Global Inbox.

So, I moved all the contents of the Global Inbox to the trash and emptied the trash.

I quit the Application and deleted the DevonThink Sorter folder. I then relaunched the application and I got a dialogue box that asked me to find the location where the sorter should go. So, I indicated that it was to go to ~/Library/Application Support.

Then when I looked in the Application Support Folder what I saw was an icon for a file, that is, it looked like a “sheet of paper” rather than a folder. I tried another Note using the sorter, and what I see is a little number 1 in the upper right corner of the box where the Sorter Global Inbox sits in the Sorter. But, when I look in the Application Support folder I see only the DTP 2 folder and no Sorter “file” or folder.

So, this time I tried clicking and dragging a pdf from the desktop into the Global Inbox in the Sorter. The number changed from 1 to 2 and I heard a little sound. But, still no Sorter folder in the Application Support folder and now I can’t close the Sorter.

So, I quit out of DTP Office. Still can’t close the Sorter. So, I think I am going to log out and see what happens.

Any help would be greatly appreciated. It doesn’t feel good to have what should be a wonderful program, not work so soon into its use. I am willing to work with it because I believe that it will be a help to me. Thank you very much for your help.

Yvonne Fried

I restarted my laptop and logged in and looked at the Application Support folder and now I find a DevonThink Sorter folder, a folder for DevonThink Pro 2, and there is now, also a Default.sorter file which looks like a “sheet of paper.”

I launched DTP Office and I have nothing in the Global Inbox. When I look into DevonThink Sorter folder, likewise there is nothing there.

I didn’t see the DevonThink Sorter on my desktop so I went to the Tools menu and Quit the Sorter and then clicked it again to “Show” the sorter. The sorter icon is on the desktop, I opened it and clicked and dragged a pdf file into the Sorter Global Inbox. There was a little sound and the “1” in the upper right corner of the box appeared briefly and then disappeared. I checked ~/Library/Application Support/DEVONthink Sorter/Global Inbox and there indeed is the pdf file that I had put into the Global Inbox. However, when I look at the Global Inbox in DTP the file is not there.

There is what looks like a pencil with a line through it to the right of the Global Inbox in the DTP Office application.

There is also Default.sorter file in the DEVONthink Sorter folder and there is a Default.sorter file in the Application Support folder. I assume I can delete the Default.sorter file from the Application Support folder.

Thank you for your help.

Yvonne Fried