SORTER is still a completely flawed piece of crap…

I love DTP… but why is the sorter so fickle… often it won’t open at all… even if I relaunch it… why is it that SohoNotes is able to have a sorter-type tool that works perfectly… and Devon isn’t ?!? How illogical is this ?!? It is really annoying as it makes it much less intuitive to use… I need to put things aside all day long in various folders/bases… and SORTER is extremely important to make it less painful… Otherwise I have to keep each base open etc.

I can’t be the only user having issues with it… no way !!!
I’m sure you are well aware SORTER needs to be rewritten !

It’s been working fine for me, even across upgrades.

Yes im having issues with sorter… items will not delete out of it… it just closes… Im using the latest version of DTOP (


I’m also having problems with the sorter. Sometimes I can add folders to the sorter and other times it just crashes. Also, if I try to remove items from the sorter it will crash. To me this is one of the best features if it only worked. I’ve contacted the support team so hopefully they’ll have a fix.


Just got an email from one of the Mac developers with a solution that fixed the sorter issues right away by replacing the sorter’s plugin file.

When I click the sorter tab, it moves away (shifts up or down just a bit, but does not open). Could someone help me fix this, it is quite annoying not having the sorter…

Hello atrain
Please, please post the fix. I am having the same problem with Sorter. Added a group to the Sorter and after that it is impossible to remove it. Sorter crashes every time. I had to solve this by re-installing DEVONthink!

My problem got solved by doing the following:

Thanks to DEVON for great support!

Same problem here. I dumped a folder from my inbox home…had been in the sorter and still appears in it. However, when I try to remove it from the Sorter, the sorter crashes. Once I got a message that the folder no longer existed and gave me an option to remove it (from the sorter)… when I clicked on remove, it just quit/crashed again.

Sorter appears still to be quite flakey?


I finally got an option to ‘recreate’ the sorter folder that was giving me fits. After I clicked on the recreate option while trying to delete from sorter, I recreated it (in global inbox), then I was able to remove it from the sorter w/o crashing the sorter. WHEW!

Sorter also gives me headaches.

Some time ago, I added a couple of folders into the sorter. Now every time I add a file of an unknown format into the sorter, it add those phantom folders into the inbox. No matter how many times I have deleted those, they keep appearing. Any help will be appreciated. I tried doing what it has been suggested here. I am just not sure how to ‘recreate’ the sorter folder.

What type of file is giving your a phantom folder?

You can reset the Sorter back to its default state of just the global inbox by:

  1. Open DEVONthink and ensure that every document you have stored in the Sorter has been transferred to DEVONthink.
  2. Open DEVONthink preferences, select the Sorter tab and quit the Sorter.
  3. In Finder select the menu option Go->Go to Folder and type the following ~/Library/Application Support and press the Go button.
  4. Find and rename the folder DEVONthink Sorter.
  5. From DEVONthink preferences, restart the Sorter

Wow, where do you find how to do that? I followed your steps. It is working now. Inside the folder I renamed, there was a subdirectory named “Global Inbox” and in there were all those ghost files that had been recreating themselves every time I used the sorter. No clue why that happened, but your solution worked. I guess I should have asked about it long time ago.


When I drag documents into the sorter, they disappear, but I don’t know where they go. They don’t show up in the inbox I can see on my open database. Nothing shows up in the DTP log --> should they? And can’t find them by searching the open database.

I attempted the “rename the library sorter folder” trick described above, twice, but no luck.

At the moment, the only way I can count on to get documents in is File > Import > Files and folders. It works, but less efficient.

I’m using DTP Office 2.3.2 in free mode. Planning to buy – it looks amazing – but I’ll admit that glitches in important functions tend to worry me in the first few days of using a product.

I hope i’m missing something easy.

My sorter disappeared and no amount of stop starting, quit/show etc in preferences would make it appear - Thanks to the earlier post in this topic it is now sorted - although I had to delete the lock file as well (listed below the one in this quote)…

I simply can not find the sorter on the side of the window.
I am unsure if I have found the right folder to drag to the trash as explained in these directions:

  1. If you are running DEVONthink Pro or Pro Office find the file com.devon-technologies.think-sorter.plist and drag to the trash. If you are running DEVONthink Personal find the file com.devon-technologies.thinkPersonal-sorter.plist and drag to the trash.

I come to a file named sorter. Is that what I am supposed to drag to the trash? Nothing is in it.

You cannot overlook step #2, where you first go to the Preferences folder inside your user Library folder. Inside that folder you will find the file 'com.devon-technologies.think-sorter.plist '. Look for a file with that exact name, not a folder. However, this recommendation is 5 years old and I don’t believe that it will work anymore. Beginning with OS X Mavericks, the OS now caches the preferences to improve performance, and the cached preference data will likely be re-written to the the new .plist file after you delete the original.

If you are comfortable with using the Terminal, the following should work but proceed at your own risk.

  1. Go to your DEVONthink preferences>Sorter tab and if the button in the lower-right corner says ‘Quit’, click on it once and it should change to ‘Show’. Then quit DEVONthink

  2. Run this command in the Terminal and enter your password when prompted.

sudo rm ~/Library/Preferences/com.devon-technologies.think-sorter.plist

  1. Run this command in the Terminal to flush the cache.

killall -u $USER cfprefsd

  1. Restart DEVONthink and toggle the Sorter preference to ‘Show’.


Open a support ticket (recommended) so that DEVON can give you their recommended solution. That’s always the best choice, especially when the information you have is 5 years old. The app itself has changed over time, as has the OS, and recommendations that once worked fine may not work, or worse, cause data loss if followed today.

From OS X 10.9 and later, you can not reliably delete the plist file manually.

  1. In DEVONthink, select Tools > Hide Sorter.
  2. Quit DEVONthink.
  3. In the Finder, press Command-Shift-G and paste: ~/Library/Application Support/DEVONthink Sorter/Default.sorter . Move this file to your Desktop.
  4. Launch DEVONthink and select Tools > Show Sorter.

If this does not work then follow the same steps outlined above but do this for item 3…

  1. Open Applications/Utilities/ and paste: defaults delete com.devon-technologies.think-sorter . Press Return.
  2. Then type: exit , press Return, and quit Terminal.