Stop Inbox tab from appearing on every login

Does anyone know how to stop the Inbox tab from appearing every time you log in? I’ve got the Show at login option in the preferences unchecked but that doesn’t seem to be sufficient.

Launch System Preferences. Click on the Accounts icon, then on the Login Items tab. Select the Sorter and click on the “-” symbol to remove it from login items.

Thanks! It worked! I actually thought I’d tried this already, appears I hadn’t.