Strange error on (re-)adding sync store

I was re-adding a sync store to resolve an unrelated issue when I encountered an odd issue on my iPhone 6 running iOS 10.2.
Prior to my removing the sync store, it worked perfectly.

  1. I removed the Sync Store (dropbox)
  2. I added the Sync store (Dropbox) which has the global inbox and one other database.
  3. when I am presented with the menu of databases to sync I am offered:

Inbox (Local)

and nothing else, even though the Inbox should be Remote and there should be an additional database. Interestingly, a HUD shows up momentarily with the name of the sync store (DEVONthink). See the whole setup here:

When I return to the home screen of the app, I see a sync error icon, so when I click to initiate a sync and view the sync log, I get an error of “Informative”:

Deleting and re-adding the Sync Store doesn’t change the result.

I noticed this on my (very old) iPad 3 as well.

I’m going to uninstall the DEVONthink To Go app re-install it to see if that helps. I may recreate the Sync Store if a reinstall doesn’t work.

The issue seems to have been related to the sync store. For some reason it must’ve gotten messed up (I tried verifying it and it returned no errors, so whatever was wrong, the verification system wasn’t picking up on it).

I deleted the sync store from all the devices and from the packet sync folder in Dropbox/Apps/Devon…

and re-made a sync store.

Successfully added it to my devices and we’re off to the races!

Do you mean online or on your local Mac?

Online, since the sync folder for DEVONthink is excluded from local sync as per my understanding of the best practices.

Excellent! Just checking (and you’re correct!) :smiley: