Strange: (Randomly but frequently) DT3 Window does not show up when launched

I am using OSX 14.2 (23C64) and DT 3.9.4. Sometimes, when I launch DT, the top menu appears, but the window is not visible. When I choose Window/Bring all to front, nothing happens.
Then I try to reopen the last database. It seems to open because the activity window shows it, but I can’t see the window. I need to close DT and relaunch again, sometimes twice, to get back to the main window. Any idea why this can happen?
Thank you very much!

Did DEVONthink or the computer crash or did you use Force Quit? In addition, did you try File > New Window?

No crash Christian and yes, I think I have also tried New Window before but I am not completely sure that I have tried this the last time I had this problem.

Did this already happen before updating to 14.2?

Yes, indeed. It happens occasionally when the system restarts, and DT is relauched.

Is the option to sync on quit enabled? Depending on the size of your databases and the used sync locations there might not be enough time in case of a restart while DEVONthink is still synchronizing.

I cannot see this option as such. Here are my sync settings (I use only Bonjour).

At the very bottom you’ll see (at least I do):

  • Synchronize Automatic
  • On Quit or Deactivation
  • Max. Connections 16

    I suppose @cgrunenberg was talking about the second line there.

I had the same issue, but was resolved when macOS updated to 14.2. I think there was a bug with that in previous macOS versions.

In my case, if I clicked once in DT icon, it opened as normal, and with 14.2 never happened.

Yes, you can then see my current settings in the screenshot.

I am already using OSX 14.2 (23C64) but continue to meet this issue unfortunately.

Please have a look at Windows > Log next time and whether File > New Window works, thanks!

I will do. I have quit and restarted DT several times, but it comes back with a complete screen. So, the problem is not systematic at all. The next time I catch it I will try these instructions.
It is quite annoying when it happens.
Thanks a lot.