Sudden Webdav SSL error -1200 when syncing SOME db's but not others!

This has driven me nuts over the last 3 days! For some reason I am getting SSL connection error -1200 when attempting to sync to my qnap nas via webdav. Out of 9 db’s I only get the error on 4 of them; the others work fine.

I’ve tried everything from deleting stores and recreating them, copying db’s to another comp, removing folders and restating them, nothing works.

Any ideas please?

We have made no changes to this code.

It’s likely you just updated the QNAP and this broke WebDAV services. If you did update it, I would contact their support.

PS: We have already had reports from someone about this being the case with the QNAP update.

Ok thank you Jim, I will contact them. I have upgraded to DT3 today and the problem seems to be recoverable if I just keep clicking the sync button. Each ten or so clicks show a small increase in the blue line in activity window. Eventually after about 200 clicks the sync completes and afterwards it occurs correctly every time. Very odd.

Supplementary question: while checking my syncs were working between machines I accidentally forgot to close a db on machine 1 while opening it on machine 2. Inoticed afterwards that I didn’t get the ‘already open on another machine’ conflict message. Are we now able to have a db running on two machines at the same time?

Thanks for your quick response

You’re welcome.

Are we now able to have a db running on two machines at the same time?

Yes, and actually this has been the case for years. Each device has a local copy of the database, separate from one another. They only affect each other via syncing.

However, to clarify to any passers-by: Multiple users cannot access a DEVONthink database simultaneously.

Ok that’s helpful thank you. I’ll let you know what Qnap say.

Best wishes

Hi Jim,

Qnap deny webdav is a problem in my case and I think they may be right. I’m panicking as I have a meeting on Weds and need to sync the work in my db’s.

This is my test which I think proves there is some problem with the files in the two db’s which won’t sync (webdav error -1200).

dbx (and one other db) will not sync on either of my Macs no matter what I try.
dby (and eight other db’s) sync instantly on both Macs.

On Mac desktop I duplicated the files in dbx to dby in DT3; dby will not now sync.
I undid the duplication removing dbx’s files leaving only the original files in dby.
dby will still not sync, even after rebuilding.

On Mac laptop dby still syncs ok.

On Mac desktop I delete the file dby, and import it again from the NAS, it now syncs perfectly again.

Any ideas please? It’s as though some files are interfering with webdav which cause an error even when they are removed, bizarre!

I was woking on my desktop before I encountered this sudden sync problem so cannot import the bad db’s again from the NAS or I’ll lose my recent work. Is there any way I can manually place my desktop db’s on the NAS and try to sync again?

Sorry to be a pain, I’ve tried everything I know from cleaning locations to rebuilding.

Error -1200 is a generic error returned by macOS if no secure connection could be established. Therefore you could try to reboot the computers and the NAS, maybe this will help. If this shouldn’t solve the issue, you could use http:// instead of https://.

Hi, yes I’ve done that several times. Don’t want to use http for security reasons. Also, the other 8 db’s sync fine by https so why not these two?

Is the sync store encrypted? In that case https is not that important.

All databases are handled the same, even names, metadata or contents don’t matter. Did you try to reduce the maximum number of connections?

Lowered max connections to 2 but still no difference

Assuming that you’ve already rebooted your router, one workaround for now might be to synchronize the databases via Bonjour.

tried http, got ‘could not connect to server’. NSURL.ErrorDomain -1004

why bonjour? that won’t help when I’m offsite, and… they other db’s work perfectly as did these two until three days ago

This a different connection issue, it’s definitely an issue between macOS and QNAP. The sync gets only the result (or in this case the failure) from the OS.

This was just a workaround. Another one might be create a new sync store and try to sync the databases via the new sync store.

yes I’ve tried that too, using the same name and a different one, still no luck.

I’ve checked folder permissions etc, all ok. What can it be? Why would some work but not others?

also, please remember this connection problem occurs on two different Macs, and only on the two same databases. It MUST be a problem with the db’s

I don’t think so but just choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - and I’ll have a look at the logs.

ok thank you

For the benefit of people reading this stream later and having this problem too I should point out that the problem was solved and was not with Devonthink but QNAP. Jim and Christian worked really hard with me over two days but the problem was definitely a Qnap firmware update FROM dated 19/09/2019 which broke WebDAV. 4.3.61070 still works perfectly.

I can’t thank the support I got here enough.

so, at last back to work…

1 Like

If I may ask, did QNAP say if/when a fixed firmware would be available? I’m running and am advised an update is available…presumably the one you ran into…and I’m also using the WebDAV server with DT3.