[suggestion] Make escaping backslashes less prominent in markdown in the editor

First, I have to say that the markdown editor in Devonthink3 gets better and better with each iteration. I was one of those fuddy-duddies who thought I would prefer to not use “WYSIWG editing” when it first appeared (but then again, I did write in to the Wall Street Journal to complain when they first started printing colour, but I digress…).

Backslashes are used in markdown to escape characters to explicitly tell the markdown rendering engine that those characters should be taken literarily, and hence not as a markdown element.

When we copy and paste from an external source into Devonthink3’s markdown editor, backslashes are inserted automatically. E.g.

image

This helps the rendering of the text in markdown “WYSIWYG editing”. And I think is especially useful where the $ appears.

However, the backslashes can be very distracting in Edit mode (at least to me! e.g. see above).

Can I suggest that in the editor, backslashes are rendered in a light-ish grey in “WYSIWYG editing” , so that visually they take less prominence in the text. It’s the same idea as reducing the prominence of comments in code editors using syntax highlighting.

Thanks for the nice feedback and the suggestion, noted.

There is already a hidden preference to address this.

Select the Help > DEVONthink 3 Help > Documentation > Appendix > Hidden Preferences. On macOS Monterey or later, Control-click the On link for RawMarkdownPasting. Then paste into the address bar in Safari, okaying opening DEVONthink.

Does that produce the expected results?

Thanks for the suggestion on turning off the adding of markdown markers when pasting @BLUEFROG .

I actually like the feature since it makes the “WYSIWYG editing” rendering better. Hence my suggestion to make the markdown markers less prominent instead.

By the way, I also know that with CMD-OPT-SHIFT-V you can just paste raw text without any escape characters, which is super useful at times (e.g. pasting a URL copied from a PDF – the colon after http is not escaped so the MD editor automatically recognises it as a link and makes it clickable).