Survey among DTTG users

Welcome aboard @Fleminghouse

Glad to hear the legacy sync is working well for you.

Yes.

I’ve just been through a similar pain and have finally got it working. What worked for me (I’m not sure if ALL these are necessary) was:

  1. DT on the Mac of 3.6.2 or 3.6.3
  2. Reduced Max connections to 4 (was 16) in the sync setup - which avoided HTTP 503 errors which appear to be the Apple servers throttling - and actually seemed to sync faster.
  3. Started anew and synced to Cloudkit from my Mac
  4. Completely deleted DTTG from my iOS devices and reinstalled - to ensure I didn’t have any “memory” of past syncs.
1 Like

Welcome @asibbald

Glad to hear you have it working. Cheers!

Oh, I forgot - I also deleted the Password on my sync - which doesn’t bother me with CLoudkit (although it would with some of the other sync locations)

Just startet playin with WebDAV sync to pCloud. Works perfectly - fast and no issues so far.

2 Likes

It works fine for me on DTTG3.

DTTG2 worked well as well.

1 Like

I can press that cloud icon as long as I want. Nothing happens. Short pressing just opens the error log showing me that the connection to my Mac was lost.

Oh yeah. It actually never worked anyway reliably. It’s apparently very hard to show a real progress indicator.

That’s what I see when I long-press the cloud icon. When a sync is in progress it shows me a progress bar and the name of the file currently being synced. Try long press after you have cleared the log.

I use Dropbox to sync about 5.5G between two Macs, an iPhone, and an iPad. It’s been working well since the days of DT2 and it continues to work well with DT3 and the new DTTG. I’m tempted to move to CloudKit, but I just saw a bunch of fixes and improvements for it, so I’m going to give it some more time to settle down. Once I see that it’s no longer being updated, then I’ll give it a try.

2 Likes

same here. 32 GB and some smaller databases, a few days in a first synch with iCloudKit, works great since then. Did work with the old iCloud service, but now it is definitely faster and immediate. I am satisfied!

3 Likes

I got the sync running via WebDAV to my Synology NAS.

Especially since DTTG3 everything is working fast and flawless. DTTG2 had some hiccups, but now I am happy.

The sync even takes place over the web, with the combination of a LetsEncrypt SSL certificate, my own domain and a static IP at home. :+1:

2 Likes

I had some initial pains moving to CloudKit but now I have 40–50 GB of data synced between two Macs and two iOS devices. Smooth as a baby’s skin.

2 Likes

Nice!

1 Like

I had a number of sync issues with iCloud (and WebKit in beta) and Dropbox before moving to CloudMe. Since then everything has been running smoothly. I do get the occasional network error when moving between networks on my phone, but other than having to clear the error log in DTTG once in a while, I’ve never had sync issues due to CloudMe.

Note that this is all anecdotal and other people may have had better experiences with the native (iCloud/WebKit) sync options, so I would keep experimenting until you have something that works for you.

I have recently switched from Dropbox sync to CloudKit for a 3GB database, which is synced across two Macs and DTTG on my iPad. I primarily use the databases for research PDFs and for paperless workflows, so there are a large number of small documents, plus some long-ish PDF papers.

Dropbox was always a bit unreliable in that I’d discover things weren’t synced and have to manually sync. CloudKit has been flawless and much quicker so far. I have “keep all” set to maximum, which works for my DB. (A 100GB database would represent nearly half the storage on my iPad, so I’d probably set this setting to be more aggressive in the OP’s case.)

Thanks for the info! Glad to hear CloudKit is behaving well :slight_smile:

I have a WebDAV server on a virtual Linux system running at a provider and sync 3 iPads, 1 iPhone and 1 Mac to this sync location.

Most of the time totally flawlessly, only some broken files after the DTTG 3.x release and after that small differences between the devices.
But now it seems to be OK

My main database ifs about 5GB currently, but will soon grow again.
I am in the process of splitting the content into 3 databases, all of them encrypted on Mac.

Strangely, iOS seems to ignore that the databases are encrypted.
They just got synced without asking for a password

At the top, there are 3 links to articles about backing up DT.

I always did this differently:

I have 3 iPads, 1 iPhone and 1 Mac synced to the same location, all of them with the same content.

This also behaves as backups and I used them for this already.
In case i run into a problem, i can resync from one of the devices that still has all content. Of course this makes a bit more work in times where I frequently add new content.

My sync location itself get’s backed up weekly and in addition, from time to time, I make an extra copy of the sync location, as archive of a former state.

Still, sometimes I would like to have the opportunity to export the content from DT or DTTG right into a filesystem.

I’m quite sure that this is not possible with DTTG, but may be possible with DT - will try to find something in the documentation.

That is correct.
DEVONthink To Go doesn’t support encrypted databases in the same way as DEVONthink on the Mac.

1 Like