sync and resolve conflict

I have been searching the forum, found lots of information but not strictly a reply to my question.

My recent workflow:

  • local db on both MBP and mac mini
  • local syncstore on NAS, using webdav (seems to be less strict in being mounted or not)
  • db’s sync upon opening an closing of db

Lately I try to use DTPO more on a file level basis as kind of a replacement of the Finder

Daily activity entails having 2 machines active simultaneously.
Both db’s open.
Adding files to each db on each machine

Up to now there is no simultaneous activity in each DTPO instance to one singular file.
So the way I understand, DTPO should just sync both directions.

Now I get the ‘conflicts recover’ window.
Apparently I can only choose between database left or database right - which is not what I want.
I want to know in detail which db record or file causes an error.
Only then can I judge what needs to happen.

Any advise how to approach this? Try Chronosync maybe?

These are the only options currently.

Who is using the other machine and working on the same file?

Though others may have their own experiences to share, I would not use Chronosync personally for syncing DEVONthink databases.

Well, I’m using both machines next to each other as I write.

Must admit there is quite some room for errors here. As I just recently started out synching I set up a local syncstore on my NAS first (SMB/CIFS). Later on, as Christian advised, I added a local syncstore available for webdav (hoping one day to succeed in making this also available from outside our home)

Now I found that by adding the syncstore on a 2nd machine I had added .syncStore myself, ending up with two syncstores similarly named but different :imp: .

So today I end up with an erroneous mix where I can’t see clearly anymore at all. :blush:


  • set up a new webdav syncstore on my nas
  • sync db’s and take extreme care to avoid naming or extension errors… to avoid erroneous duplicates
  • when all is well and in sync -> remove the faulty cinctures


  • Is there any way to delete a remote syncstore using DTPO?
    Or can this only be done on os file level on the NAS itself?

  • looking into the Syncstore, I see the db’s have numerical ID’s - are these UUID’s?

  • is there any way in DT to see this UUID? I’ve looked under db properties to no avail…

Strange issue…

On my MBP I have a small database named ‘administration’.
I’m trying to get this ‘administration’ db to sync over to my originally named newstore syncstore (on the NAS, webdav).

So all this happens on the MBP.

On my mini, I have now added the newstore as well.
Then I click import db, select the newstore, and it says no db’s are found…???

[for what it’s worth, I already tried this before setting up the newstore syncstore…]
No clue what is going on here… :question:

You can only delete the Sync data, not the syncStore itself. That has to be done manually.

It can be accessed through Applescript. It’s the UUID of a database.

tell application id "DNtp" to get uuid of current database

If a database is open on a machine, it will not be seen as an importable database from a Sync Location.

Jim, why do you keep all this information so secretly hidden till the last minute? :laughing:
Makes me wonder what you guys still have up your sleeve that I’m not aware of… :wink:
No kidding, that is extremely important information…
I need to take this into account in my workflow.


  • One more thing: In my enthousiasm I seem to have created databases in different locations.
    I’d like to set this right.
    Is it ok to:
  • close db
  • close DTPO
  • move the db
  • DTPO and open the db in it’s new location

Are there other rules of thumb to take into account?

This is the appropriate way to do it though you needn’t quit DEVONthink to do it.

No intentional secrets, but always something to learn. :smiley:

I’m still having import from webdav syncstore issues.
After creating the new webdav syncstore, I synced 2 db’s over.

Closed the db’s. Later on even quit DTPO.

On the other system, tried to do an import from the same webdav syncstore…
At one occurrence it showed one of the 2 db’s, but not the one I wanted to import.
Later on it didn’t even show this one, but it showed no db’s at all.

What can be wrong?

Please start a Support Ticket.