Sync doesn't seem to work with multiple routers

I have a dual-router setup at home, with a Time Capsule on 5.8GHz and an Airport Express on 2.4GHz. When I first tried to set up synching with DTTG, my laptop was on the 5.8GHz router – my iPhone and iPad, of course, only work on 2.4GHz. Even though they “saw” my laptop in Bonjour, nothing happened when I tried to sync (and the lack of feedback is a real pain!).

I moved everything to another room, where the laptop connects on 2.4GHz because the 5.8GHz signal is too weak; syncing worked right away.

It appears that the laptop and iOS device might need to be on the same router – I don’t have a dual-band router to test to see if they have to be on the same frequency, too.

David Singer

Hmmm… This may explain some oddness I have been seeing. Thanks for posting the comment. (Did you file a bug?)

David, can you say how the two routers are connected? e.g. Is one bridging the other network or using NAT on its own or what?

I just filed the bug – thanks for the suggestion!

Sure. The Time Capsule (on 5.8GHz, 802.11n only) is the main router; the Airport Express (on 2.4GHz, 802.11n/g/b) is physically plugged into one of the TC’s Ethernet ports.

The Time Capsule handles DHCP for the whole house (wired, 5.8, and 2.4 clients). Both units are set to “Create a Wireless Network” in the Airport Utility, and both have the same SSID and password.

Hmmm. I just reset the Airport Express configuration to exactly the same as it was (or so the Airport Utility claims), and now I can successfully sync between the iOS devices on 2.4 and the MacBook Pro on 5.8.

It looks like bridging wasn’t quite working right for some reason, but it appears to have been a local network problem, not one with DTTG.

Sorry for the false alarm, but maybe this can help others debug their networks.

(And I agree…Dropbox sync would be nicer anyway!)