Sync Global Inbox & missing database (Dropbox Sync Store)

Hello, I’m doing experiments to find the best workflow between my two Macs and DTTG 2 on an iPhone. I already had two Macs syncing nicely with a Dropbox sync store and three databases plus the Global Inbox. I tried adding the sync store to DTTG 2 and I’m encountering some weirdness.

First is the Global Inbox. It seems to sync flawlessly between my two Macs, but is weird on the iPhone. If I create a file on the iPhone, it shows up on the Macs. However, if I edit the file on the Macs, the changes don’t show up on the phone (edits on the phone do show up on the Macs). Additionally, any files created on the Macs show up to each other, but never show up on the phone. Is synchronizing the Global Inbox not supported in DTTG 2?

Next is the case of a missing database. I have the Global Inbox (shows up as Inbox) in the Sync prefs), and three databases: Personal, Reference, and Technical. These all work great between the two Macs. However, in DTTG 2, I can only see the Global Inbox (which shows up as Global Inbox in the sync prefs), Personal and Technical. Is there a limit as to how many databases can be in a sync store? I tried deleting and reloading the Dropbox sync store, as well as fully deleting and reinstalling DTTG 2 from my phone. My “Reference” database just won’t show up to DTTG 2.

Thanks for any help people can offer,

I’m only seeing the inbox as well. My other folders will also not shop up.

Make that three of us. Works fine on my iPhone but no databases visible on my iPad. Re-establishing the link, or adding additional items to the database did not change the situation. FYI, I am using Box as my sync method.



DEVONthink syncing has never, ever, been straightforward or intuitive; which I don’t understand. I have numerous other apps that do this just fine, including with iCloud where I have purchased extra space.

Currently I might be fixed. What I did was delete DT2G from my iPad and restarted the iPad. Quit the database in DTP on my Mac, quit DTP, and restarted my Mac. Before even downloading DT2G on my iPad I set up Bonjour in DTP on the Mac with a password. I then dl’d and opened DT2G on the iPad. Started it up, went into the sync and entered the password that I had set on the mac, then it gave me two sliders, one for the Global Inbox and one for my primary database (which I had open on the Mac side). Not the sync appears to be working (will take a long time).

Why it is this hard is beyond me. I believe I read that DT2G 2.x also can’t use iCloud, which is a real drag because that’s where I’m paying for storage space. Don’t really want to pay another $10/month to Dropbox.

Sync is simple. It has always been simple. Sync 1 had weaknesses (which lead to our new Sync engine’s creation), but they are fundamentally the same setup process. A Bonjour connection is really only a little more complex than setting up an online account (and only because you have to “turn on a server”).

PS: Simple doesn’t mean “perfect” as there are things that can inhibit any network connection. Poor network conditions are one of them (and this is only really ascertained my diagnostics, not by saying, “My Internet is 25MBs.”). Also, this is not a 2.0 release. It is a 1.0 release of an application that shares a name with our former application.

Sorry, but as someone who has numerous apps that sync with iCloud the DT sync is NOT simple. Syncing should be, in fact, nearly transparent to the end user and not require all this diddling around with settings, etc. My sync is finally working after going through the list of things I mentioned above, which should not have been necessary to get a routine sync to work.

that is why the three folks in this thread cannot get it working… why are you always so defensive? it is such a childish and unprofessional attitude

I also think that DEVONthink sync is neither simple nor easy to configure. After many attempts (I don’t know how many times I downloaded and reinstalled the app in my iPad Pro and iPhone) I quit.
I will keep on using Evernote until I find some documentation I can understand in order to sync my databases.
I am really sorry; I thought that this app would even change my workflow, and that it would be the “final” app.
I am so fed up with these sync issues (it reminds me of the first years of using Linux) that I am even thinking of coming back to open software…

They are not normally necessary.

You were already asked to quit being so defensive. I’ve been using DT practically since it came our and I have trouble with parts of it. Grow up and admit when things aren’t working as seamlessly as they should.

To make it clear, as one of three folks reporting a bug, I have no issues whatsoever with the folks at DEVONthink. I know how long they have worked to make their sync solution work, how many iterations they went through to get here and how hard their beta testers have worked as well. I do not realistically expect version one of any complex solution to be without a few quirks, nor do I doubt, based on past history, that the DEVONthink team will get these quirks ironed out in short order.

It has been my observation that numerous first class developers have concluded that while iCloud works for syncing with file based applications, it currently is not a workable solution for syncing database type files. Just last week, Scrivener for iOS was released, syncing to Dropbox but not iCloud, for that very reason.

So I thank the team at DEVONthink for their hard work on creating a reliable sync solution, and hope I, and others, can help them resolve any existing glitches.

with some much needed Aloha from Hawaii,


Thanks for those remarks, mprazoff. :slight_smile:

The new Sync routines for DEVONthink Mac and iOS are a complete rewrite. Doing development they have been tested, initially internally and then extended to a group of beta test volunteers before release to the public. While numerous bugs and quirks were ironed out during testing, this is a “1.0” release in the sense that it is now exposed to a wider variety of hardware and user workflows, just as Apple’s attempts with public betas of OS X revealed bugs still to be dealt with after release.

Jim’s description of Sync as a simple process is correct. But it is “simple” and works well in most cases if the user adapts to the processes as spelled out in Help. Erroneous preconceptions of how it “ought” to work will cause problems. It helps a lot to get one’s head around the concepts of “always download” and “download on demand” in setting up Sync. This becomes important especially if there’s limited storage space on an iOS device.

One of those preconceptions is that DEVONthink Sync for iOS should work with iCloud. But Apple’s current iteration of iCloud doesn’t provide for that.

I’m delighted with the overall improvements of DEVONthink To Go 2.0 over the first generation. I can now do much more with my DEVONthink databases under iOS than was possible in the past. And I’m delighted by my iPad Pro 12.9-inch and my iPhone 6s+, both with substantial storage space. My mobile devices are more useful, yet I remain in full control of my data.

But much of my DEVONthink work will be best done on my MacBook Pro, with a fast 4-core CPU and 16 GB RAM, operating under the full implementation of OS X. There, I’ve got features such as AI assistants and scripts that are not available in the more limited iOS/hardware of my iPad and iPhone.

Hello All,

I think we’ve gotten off the rails a bit here. Hopefully my initial post didn’t come across as complaining: I’m simply trying to figure out why sync is not working quite properly for me. I’m also checking to see if I’m trying to get sync to do something it isn’t designed to do. I fully appreciate the hard work the developers are doing, and I’m personally glad that DTTG 2.0 took this long to come around: contrary to what a few people seem to think, sync is not a simple problem. There are many edge cases, and I appreciate the time taken to get the most stable product possible out initially. That said, there’s no way that internal and even beta testing can catch all the weirdness that we as users will do, so that’s why we have forums. If one wants a seamless transition, the best idea is to never install a .0 release. Wait until two to three updates have come out.

Now that I’ve taken us off the rails even more, could we get back to my initial questions? I’ll recap, and add some new information.

  1. Should it be possible to sync the Global Inbox between iOS and Macs using a Dropbox Sync Store? If so, please see my notes in the initial post as to the issues I’m personally seeing.

  2. Regarding the missing database. Since I’ve first posted, I completely deleted my original sync store and set up a new one (with a new name) on my iMac. I then synced each database, once at a time to my Macbook Pro. I confirmed that it worked between my iMac and MacBook Pro. Then deleted DTTG 2 from my iPhone (iPhone 5, 64GB, iOS 9.3.3) and reinstalled. Interestingly, when I went to set up the Dropbox sync store on the iPhone, it did not have me authorize Dropbox again (I’m not sure if this is normal behavior). I can now see all of my databases. First I tried syncing just the Global Inbox, and it gave me the same behavior as previously described. Next I synced each database, one at a time. Initially, two of the three were giving me manifest errors in the log, and came up empty. I turned off the sync on both of the problem databases & deleted the databases from DTTG. On my iMac, I used Tools > Verify & Repair on the two problem databases. I also used “Verify Database Quickly” on each of them from within the Preferences > Sync tab. One of them then started to work properly when I synced it again on my iPhone. The other still has issues. When I turn it on in for syncing in DTTG, I only get the spinning wheel very briefly (the other databases take a few minutes of wheel spinning). I am no longer getting sync log errors, but when I view the database, it is empty.

I bought the premium features, and I’m using the metadata only synching. The database in question is 615MB, and is mostly made up of images and video files. One of the other databases that is working is 950.2MB and the other (also working) is 1GB. I have tried rebooting my phone and Macs.

One possibly interesting note is that after turning off the sync on the problem database on my phone and deleting the database, when I initially went to turn on the sync, DTTG said that it was in the process of deleting the database. This took a little bit to clear, and then changed to saying it was Remote.

If this isn’t something that can be addressed in the forums, please let me know. I’m happy to start a support ticket. I started it publicly here in the hopes that someone would have an easy fix/answer and everyone could share from that knowledge.


Nope, not at all. But it is a matter best suited to a Support Ticket.

  1. Yes
  2. Definitely, Support Ticket :smiley:

Thanks Jim! I’ll get one set up soon…

Before I set up my ticket, one more question. Should I do one ticket for both issues, or one for the Global Inbox and one for the problematic database? I want to make it as easy as possible for the support team to track my problems…

You can put them in one, as they’re likely intertwined.

I have a similar situation (and I have created a support ticket).

I have both my iphone and my ipad pro set up for bonjour and connected to my mac’s devonthink pro.

On my ipad pro it gives me the option to sync my inbox and my devonthink pro database

On my iphone it only gives me the option to sync my inbox.

@nickbo: Are you trying to Sync both devices simultaneously?

No I’m not. I have synced neither yet, just set up the connection. I started syncing my devonthink database on my ipad last night but stopped it because I didn’t have enough space.

Today I set up my iphone for bonjour and noticed it didn’t have the option to sync that database while I did have the option to sync it to my ipad.

I deleted both locations from my devonthink mac sync setting page, and turned them back on (one iphone and ipad I turned off and on the bonjour slider), and same thing happened.