Sync help! Different versions on all 3 devices

Hi all,

I seem to be in a real sync muddle right now.

My setup: iMac with DT 3 Pro, DTTG on iPhone and iPad, all syncing (supposedly) through iCloud.

I’m now in the position where:

  • DTTG on iPhone seems up-to-date
  • DTTG on iPad crashes every time within a few minutes of launching (tried rebooting the iPad)
  • DT 3 Pro on the iMac says it’s synced, but definitely isn’t showing changes that are showing on my iPhone and iPad (before it crashes). On the Mac desktop version there are a lot of tags showing, with associated documents, that’d I’d moved elsewhere or deleted on the iPad before it started crashing. Those changes DO show on my iPhone, but not the desktop.

So now I’m not really sure where the definitive version of my databases live.

I’ve raised a support ticket re the iPad crashes, but in the meantime does anyone have any idea how to re-sync everything?



Try to manually synchronize the iPhone, wait til it’s completed, then synchronize the iMac. Does this make a difference? Are any issues logged?

Thanks for the reply. How do I perform a manual sync on the iPhone? The app is telling me it last synced about a minute ago, so looks like it is auto-refreshing. And I’d tend to believe that, as it’s picked up the changes I made on the iPad. But my Mac isn’t reflecting those changes.

Which macOS version do you use on the Mac? On the Mac try File > Synchronize.

Mojave 10.14.6. I tried File -> Synchronize, but it didn’t seem to make any difference (e.g. the tags I deleted on the iPad are still on the desktop version). Although, some syncing is definitely taking place. If I create a new text file on my iPhone, that gets sync’d to the desktop. But, all the tags I’ve deleted on the iPad are still there on the desktop version.

You can try this to reset the sync in DEVONthink To Go…

  1. Press the Help icon in the bottom toolbar.
  2. Go to Appendix > URL Commands > Performing Service Tasks .
  3. Press the Execute link under resync .
  4. Quit and relaunch DTTG.

Thanks for this - this seems to be helping with the iPad and iPhone. However, the problem seems to be persisting on the desktop. Is there an equivelent for the desktop version to force a resync?

What is reported in DEVONthink’s Window > Log?

Nothing shown on the Log when I do a sync on the desktop

In DEVONthink’s Preferences > Sync, disable and re-enable the iCloud sync location. Then sync it and see if has any effect - obviously allowing a little time for iCloud to do its own thing.