Sync issue between DEVONthink To Go and DEVONthink on my Mac


I have scanned a week ago some documents on my iPhone and added them to DEVONthink To Go.

On my Mac the documents appear on the Inbox, but most of them are not accessible.

The file icon is not the mini-preview of the file, but some kind of faded pdf-file icon + on the right some kind of cloud sync? icon. And when I’m clicking on the file it says “File not available” + a “Download” button :

I’ve tried clicking on the “Download” button, but nothing happens :

On the iPhone the files are available, I can see them, but in the list it seems to be the same thumbnail issue :

vs the same files on the Mac app :

  1. I did not see any errors during the iPhone sync
  2. I tried syncing multiple times on both devices
  3. tried to close the app on both devices and retry the sync afterwards
  4. tried restarting the devices

… I have no more ideas left.

I’m lucky I’ve checked the files, but I really hope that’s not an issue and that I can have the files on my Mac too… Because the documents I’ve scanned have been destroyed afterwards :cry:

Any tips ? Anyone else had issues like this ? Is there anything I can do to force the sync of these files ?

Any help is appreciated :pleading_face:

Later Edit : forgot to specify the versions :

DEVONthink To Go : v3.1.1 (17082)
iOS : 14.6

DEVONthink : v3.7.2
macOS : 11.1

  • Is there anything reported in DEVONthink’s Window > Log?
  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it and tell me what it reports.

Also, the current version of macOS Big Sur is 11.4. You should stay current with the operating system and our point releases.

1 Like

No, nothing there…

I do not have the triangle indicating errors…

I updated my macOS this morning after seeing your message, but it didn’t helped.

Isn’t it a way to force sync or something? Right now I’m starting to really doubt the syncing mechanism of the iPhone app and I’m afraid to use it anymore…

You didn’t say which sync method you’re using. Maybe you could try with bonjour which has the reputation of being fast and reliable.

You are right. I use CloudKit

Then you might want to try bonjour, n’est-ce pas?

1 Like

Hold the Option key and choose Help > Report bug to start a support ticket.

Done, thanks