Sync Issue From One Mac

I am having problems syncing databases via iCloud to one of my Macs running Big Sur (in case it matters). I’ve upgraded to DevonThink 3.6.1. I see the sync dot on all my databases I’ve tried to force a sync by going to File > Sync however there is no activity in the activity log.

When I went into the sync preferences I noticed it hadn’t synced since August. I thought I would just fix the problem by deleting the local database and re-importing it. However, now the sync status says “Not yet synchronized, merge with remote database”.

Any ideas?

Deleting what local database?
Screen captures could be helpful.

I do see this in the log

I have the exact same problem. I just bought a new MacBook Pro (M1 Processor) and installed DevonThink 3.6.1. I tried going to iCloud and just importing the database from iCloud instead of copying the database files over from the old MacBook.

Under Preferences - Sync - iCloud underneath the database name it says “Not yet synchronized, merge with remote database” and my log every 10 seconds or so has an entry that says "Can’t create folder of database “”, path exists already.

I see the new database over in Open Databases, but it’s empty. Closing and reopening, File > Synchronize… nothing seems to get it going.

I do have one database synchronized with OpenDrive (WebDAV) and I just imported it and it is working.

ONE out of nine iCloud databases downloaded correctly. The other eight give this error. My log looks exactly like the original poster’s screenshot above.

I manually deleted the folder under Mobile documents (it just comes back) to see if that would fix the issue. However, it didn’t.

I uninstalled DevonThink. I have Hazel so when I moved the app to the trash can it asked if I wanted to delete associated files in the preference folder among others.

After I reinstalled DevonThink I could get sync working and has been working ever since. I don’t know if it was a combination of those two items together or just the reinstall.

Mine was a brand new install, first database ever tried, if that helps.

Clean the sync location then resync.

Is cleaning the sane thing as erasing? Or is it more like tidying? LOL

It is removing the sync data so databases can be synced afresh.

Gotcha. I’ll start working on that. No telling how long it will take to re-upload all those databases. Any idea why the sync stores were corrupted? Is there something I did wrong on my end?

Not likley you did something wrong. It’s a bit unusual if this is the very first time you’re setting up sync.

Was there only one database reported as a problem?
If so, you can clean just that database by selecting the sync location and Control-clicking the database in the Databases list on the right.

My setup was 11 databases DT 3.6.1 on the old MacBook. Nine were synced to iCloud to provide syncing for my iPhone and iPad, and two were synced using OpenDrive because I was having problems a few months ago that I think I posted about where DT or DTTG was changing the format from Formatted Text to HTML and could only be edited on one device (the last one to save).

I installed DT 3.6.1 on the new MacBook and tried to go into Preferences > Sync > iCloud and import the databases using sync instead of copying the database files. Only one database would import from iCloud – the rest had that error. So I did what you said and cleaned the 8 non-importable databases, and I am re-syncing from the old MacBook now, and they are now syncing correctly on the new MacBook as they become available on iCloud.

Thanks for the suggestion – it worked – I was just curious why it happened and what I might do to prevent it in the future.

Can you clarify how you accomplished this?

How do we verify and be sure that ALL items on one device have been synched to another and visa versus?

OpenDrive has WebDAV support.