Sync problem in DT3 where items do not download

  • I use DT3 across two MacBooks (and DTTG, on an iPhone – just bought a subscription!)

  • I noticed, when searching for something, that the item showed as “not downloaded”, and showed a “Download” button.

  • Clicking on the Download button did nothing.

  • I was surprised and checked the other MacBook, and the item was very much present there.

  • I have tried quitting and restarting DT3

  • I have tried clicking “Synchronize”

Any clues/suggestions?

(Note: I recently retired an old personal Macbook and switched to a newer one, and that is the one with these sync issues. I am using the M1 version of DT3, if that matters at all)

Thanks in advance,

  • Have you verified the file is available in the database in DEVONthink?
  • Have you done a File > Verify & Repair on the database on the Mac?
  • What kind of sync are you doing?
  • Yes, the file is available, I see it on a different device
  • Yes, I’ve done File → Verify & Repair
  • I use iCloud sync (the new, CloudKit version)

I see this when I try to access the file. I also see a little grey “cloud with dotted line” icon next to the file in the list.

Is a verification of the sync store successful too? Do you remember on which device you’ve added the file?

Hmm, what does “verification of sync store” mean here?

I did verify it locally on the device.

Yes, there is a device where the file exists.

In DEVONthink’s Preferences > Sync, right-click the sync location, hold the Option key and choose Verify Location Thoroughly.
The results will appear in Window > Log.

Thanks, this is a great tip to know about, I will try it right away!

Meanwhile, I did try another thing that didn’t work: deleting the database and re-importing it.

You’re welcome!

  • Did the file originate in DEVONthink or DEVONthink To Go?
    • If DEVONthink To Go, are you seeing the file in there?
      • If so, duplicate it, then sync DEVONthink. Do you see the file in DEVONthink now?
  • Tried the “verify location thoroughly” step, didn’t make a difference

  • File originated in DT3

  • fwiw, DTTG has the same behavior as DT3, btw, in terms of not being able to download “some files” (including this one), but I somehow have a lower bar about DTTG retrieval.

  • Is it an indexed file?
    • If so, do you have Synchronize contents of indexed items disabled in the Info popup for the sync location in DEVONthink’s Preferences > Sync?

Thank you for yet another cool tip!

More details:

And which device did you create/modify this document? Is it available on any device?

Yes, I can see it on one device, but not the other.

Modify & save the file on this device & synchronize the database. Is it available on the other Mac afterwards?

Finally got around to trying it and it worked, for just that file!

(Others exhibit the same behavior though)

Does this mean DT3 thinks it’s synced the rest but hasn’t?

Also, when I open it in DTTG I see the contents and I wasn’t seeing it before but … I see a gray square flash with “complex document, opened read-only” … does that help?

It’s hard to tell whether DEVONthink 3 didn’t receive or DEVONthink To Go didn’t send the data without having a copy of the same sync store.

That’s not related, it’s a limitation of DEVONthink To Go and its current editor.

I tried it for more files, and it worked perfectly each time

i.e. the following steps:

  1. [on mac-2] find the file, unable to view or download
  2. [on mac-1] modify file (add some whitespace)
  3. [on mac-1] synchronize
  4. [on mac-2] synchronize
  5. [on mac-2] file the file and download

Given that this works on an ad-hoc per-file basis, is there a clue to what might be wrong that would resolve it for all files in the database ?

Thanks in advance!

It’s obviously a sync issue. But it’s still unknown when and why this happened, which versions of DEVONthink & DEVONthink To Go were used and which is to blame and whether the bug has been already fixed. The easiest fix is probably to clean the sync store and to upload & merge the database again.

You’re right, what finally fixed this, in the two databases that were giving me issues, is doing the following:

  • close the database on the ‘bad’ macbook
  • delete the database file
  • clean the sync store from the ‘good’ macbook
  • re-upload from the ‘good’ macbook
  • re-import from the ‘bad’ macbook

All good now!

1 Like