sync problem

I had several items in global inbox which synchronize to my DTTG. This morning I moved those items to another database sync group that also synchronizes to DTTG. The problem I’m seeing is that DTTG doesn’t reflect the move I made.

In other words, now I have nothing in my global inbox and previously items in that group is in my database sync group, but my DTTG still show those items in the global inbox but not in my database sync group.

No matter how many times I tried to sync or rest the sync setting, this persists.


This just happened to me today, too. Very frustrating. I just got over my fear of syncing after losing data last weekend, now this. Well, it’s an improvement I suppose. :unamused:

We are working on a fix for this issue. In the meantime, you need to reset the application (not tapping the Reset button on the sync screen). To do this, go to the iPhone/iPad Settings application, scroll down until you see DTTG, tap that, and set the “Reset” switch there to ON. The next time the app launches, it will clear your database and you will need to resync.
We realize this is not a viable option going forward, and this matter will be addressed in update 1.0.2 (or 1.0.1 if we have a good fix the problem this week).

Thanks for the update, Mike. As workarounds go, that one doesn’t sound too bad, and I look forward to the update. :smiley:

Reset function doesn’t seem to be working with iOS 4.2.

The only way I fixed it was the uninstall and reinstalling the program and then syncing it again.

Just FYI, iOS 4.2 is prerelease software and you are in violation of Apple’s NDA by discussing it here. If you are having issues with Apple products you should not be discussing in public, please file a bug report with us.

I believe I did not disclose anything about iOS 4.2 in my post per agreement. The only thing I mentioned was it is not working with Devonthink. I would be happy to give you more details privately, but I thought others would like to know.

BTW, I have stopped using DT to Go for now given all the sync problems. I am now using another competitor’s program that seems to work reliably. I am sorry to say.

The workaround does not work on iOS 4.2. Now we can openly talk about it since it is released today.
Any workaround in 4.2?

Please let us know if anyone still sees the problem with reset not working on our 1.0.1 release of DTTG (released yesterday). It was built and tested on 4.2, and the reset function appeared to work correctly on the last beta of 4.2.1 we received.
We plan on releasing updates to DTTG every two to three weeks for now to address critical issues users are finding with the product. If reset appears to be a problem for users on 4.2.1, we will get an update out in the next few weeks to address this issue.

Just updated to ios 4.2, DTTG 1.01, and i’m running DT 2.0.6; reset seems to work since i do get a sync code question. However i now have a problem with actual syncing. Strange enough after i fixed my first problem (my macbook didn’t have a bonjour name) all worked fine for a while, but now if i click my computername in DTTG it just lights up and that’s it… nothing happens. I didn’t change anything as far as i can tell, and also didn’t install any new software, except the last macos update last week. If tried a couple of resets and even installed DTTG from scratch but no luck so far… Any suggestions?

Ps. the log in DT says “connection to device timed out”, so they do seem to buddy up somewhere…

I am posting this as a fresh topic on the Forums, but it might help to repeat this here:
“Make sure that your Mac firewalls have an exception set for your DT desktop product (in System Preferences, go to the Security icon, select the Firewall tab, click ‘Advanced’, and add your DT desktop product to the list of “allowed” applications). If that fails, then try creating a “private network,” go to the Airport icon in the menu bar (or in System Preferences, Network) and choose “Create Network…”. This allows you to create a network just using the WiFi on your Mac. Create a network and see if you can sync your device over this ‘private’ network. If this works, it means that your WiFi router is either dropping a fair number of packets when communicating between your device and the Mac or the WiFi router is blocking our protocol. It should be noted that we use our own protocol for communicating between the desktop product and your iOS device. While more secure, it is also somewhat less robust than higher-level protocols like HTTP when it comes to dealing with dropped packets. And while known protocols like HTTP or FTP are “understood” by WiFi routers, if security features are set to ‘high’ on some routers, they may see our protocol as being suspicious and block it. In any event, please try the above steps and let us know if they have any effect. If the “Create network” approach works, then you might need to look at your WiFi router’s settings to see if there is something blocking our traffic. In any event, let us know what you find after trying one or both of these approaches.”
In this particular case, it might be useful to see if distance from your WiFi router (on the part of the device) makes a difference. As noted above, our protocol is slightly more susceptible to vagaries of network traffic (even on a closed, home network). We are not suggesting you need to keep your device next to your router in order to sync, but from personal experience there are areas in a house where WiFi “works” but is still dropping a lot of packets, which will cause our network stack to time out.

The reset seems to be working with 4.2.1 and DTG 1.01. Thanks for the fix.

What is 4.2.1? I have followed the advice above and my iPhone doesn’t seem to be able to recognize the computer. They are on the same wifi network, the signals appear strong, I’ve tried the private network, but nothing works. Is there anything else to do, or do I need to wait for an update? I have DTPO 2.0.6 and DTTG 1.0.1. Thanks very much, Keith

I figured out 4.2.1. And, although I’m not sure why, it eventually worked. I suppose it could be the instability indicated above. Sorry for the wasted time/words!

For me the reset trick functioned well, but immediately after, the same behavior of the global inbox continues.
This makes the global inbox completely useless as everytime I add something it remains in the global inbox of DTTG even if i move it from the global inbox from the Mac.
When do you think we will have a fix for that behavior ?

I had DTTG working. Upgraded to iOS 4.0.1 – had the app getting stuck in the sync window. I though I was running DTTG 1.0.1, but realized that I only thought DTTG was upgraded to 1.0.1 - turns out it was not. When I did upgrade, things were working. So, if you upgrade you OS, be sure to upgrade your apps. I synced up 315 docs, no problems.