Sync seems to be stuck on `not yet synchronized, upload database`

ok so had a bit of a reading of the help file as suggested and setup bonjour

so do i understand correctly that for me to sync the mac to the iPad i need to also alongside this use Webdav to do the actual syncing or am i way off?

sorry for being very non technical :slight_smile:



“Way off”. What did you read to give you that impression? Please quote the page number on the Hanbook.

Also, before you get all into synching … best to make sure you actually need it.

thx again @rmschne :slight_smile:

well yes i want to have my food and tech Databases available with me on all my iOS devices so there is a need :slight_smile:

as of where i got it, well i enabled bonjour on the mac and then on the iPad (not checking allow incoming connections) yet nothing really happened. i assumed i need to do something to define which databases to sync and how to do so but this is where i got lost :smiley:

as you can see on the mac i can see the iPad yet i dont get an option other then inbox to choose what to sync


A correct setup on Mac for Bonjour does not show to you the other devices. I do not know for sure what you have done, and since I don’t know for sure I’m not going to speculate. The best instructions (better than I can or will re-state here) for how to setup Bonjour are in the Handbook, which I suggest you re-read and follow exactly.

Clue: configure access on the iOS devices TO the Mac that accepts incoming.

Final advice: do not overload the iOS device with a huge amount of data that just causes you to say “it takes a long time” as lots of data will indeed fill up the device and take a long time. Your mileage may vary, of course.

thx again

after reading this post

things finally made sense (sorry for me the handbook wasn’t as clear as that post…maybe its just me…)

anyway after i setup everything im getting the mentioned:

General CFsocket error / AsyncSocketErrorDomain 2


i don’t have the firewall activated on the mac (the Devonthink server) and rebooted all macs, iPads and iPhones but still cant connect

would really appreciate any help to debug this…



Relied on a Post and it didn’t work. Humm…

I quote from page 61 of the DEVONthink Pro 3.6.3 Handbook these clear and simple instructions without edits. No post anywhere is more clear or simpler.

Bonjour Setup:

Step 1: On the machine acting as the server, open Preferences > Sync and press the Bonjour Options button.
Step 2: Click Enable Incoming Connections to use this Mac as a Bonjour server of
its databases. Optionally, have closed databases open when a client initiates a sync.
Step 3: Enter a mandatory password. This password is required for other devices to act as a client of DEVONthink’s. If you are working with an IT department who has assigned a port for you, or you have a port you’d specifically like to use, enter it in the Port field. Otherwise, leave this blank and DEVONthink will assign one for you.

The Mac with Bonjour enabled should now be visible as a sync location to other devices on your local network. On the other devices, enable it, enter the password, and you can import databases or sync existing databases directly with it.

Note: You should never use more than one device as a Bonjour server for a given database.

  1. The first place you should always look when having a potential sync issue is Window > Log.
  2. Bonjour is not only covered in the Help referred to by @rmschne, but I did a more exhaustive dive here:

thx @BLUEFROG , as always your help is top notch

first of all your link and your simple instructions were IMHO much more clear then the help file (at least for idiots like me… :slight_smile: i highly suggest you move that to the help section…just my 2 cents…)

back to the point. i did follow all your instructions on the mac and the iPad up until the point of the

Set the options per your choice and touch Save.

then i get this error

i am using latest big sur and latest iOS (14.5), latest Devonthink , have no firewalls one mac or router, and all devices are on the same LAN and seem to see each other on the network

any clue how to resolve this?

kind regards


Fyi @BLUEFROG author of both.

1 Like

That is a transient error.

Try quitting and relaunching DEVONthink and DEVONthink To Go.
You may also consider rebooting the Mac - not just because it’s good to do occasionally (weekly is nice), but in case a port was stalled.

first of all your link and your simple instructions were IMHO much more clear then the help file (at least for idiots like me… :slight_smile: i highly suggest you move that to the help section…just my 2 cents…)

I’ve considered it. However, I have to consider large scale restructuring and it’s affect on the PDF, .MOBI, and .EPUB as well.
So far, the succinct presentation in the Sync section seems to be successful so far. :slight_smile:


i did reboot both the Mac and iPad but the same error still appears

i currently cant get either bonjour or CloudKit to work so cant sync…would appreciate any other ideas on how to try and debug bonjour

thx again


You didn’t respond to this earlier.

sorry about that

the current log window seems to have nothing

would be very happy to provide any other missing information



By chance are trying to setup a Local Sync Store? The location name you are showing should not be part of the Bonjour setup (per the instructions we’ve pointed you to). If so, why? If not, where are you entering that location name zeltak@itas-macbook-pro-113? Should be no location name for Bonjour and Cloud Sync, far as I know. Of course, I could be wrong. Re-read the instructions, please.

Have you looked at the IOS devices running DEVONthink ToGo to check that they are set to connect to the Mac via Bonjour?

thx @rmschne

i don’t think im seeing up a local sync store. i have followed (or tried to follow :)) @BLUEFROG 1:1

to make it clear this is what i do:

on the mac i only configured the bonjour settings:

(as you can see no local sync is checked)

on the iPad i do the following:

so when i enable the location i get this same error

did i screw something in the process?



Good to now see the relevant screen shots. Sorry, network stuff above my pay-grade.

I did a search via Google for “asyncsocketerrordomain 2” and found:


which my hunch is the direction towards solution. There are other “hits” on same keywords involving other products, but all point to network settings on the devices.

In addition to doing a ‘reboot’ try shutting down completely both devices, leave quiet for a a few minutes (for it to forget everything), then restart. Sadly, works sometimes.

thx again

yes i don’t have a firewall enabled anywhere and don’t have little snitch installed

i will wait to see what @BLUEFROG thinks

thx and best


Others can comment, but would an SMC reset on Mac be in order?

I tried this on my machine to test the ports open. DEVONthink chose to use port 63262 and it works so I didn’t change it.

From a terminal, issue the command:

netstat -a | grep -i “listen”

which will list all the “open” ports available to “listen”. for me the results were:

Which tells me the designated port is open and taking connections. You see the same for your port (per screen shot) 56283?