Sync timeout with DTTG 1.1

With DTTG 1.1 and DTPO 2.0.9, syncing works great with my iPad (1, 4.3.1). However, it fails with my iPhone 4 (also 4.3.1).

If I sync ONLY my Global Inbox, it works.

If I have ANYTHING in my Sync group, syncing hangs: I get the message “Preparing Sync” on the iPhone and, on the Mac, “Synchronizing Items to Device/1 of X: Determining which items need to be sent…” which persists for a couple of minutes until it times out. Then I get a “Connection Lost” message. This is the case even when there is only a single, trivially small file in the Sync group. Infinitely repeatable.

I’ve tried resetting sync on the iPhone (several times), force-quitting, and even deleting the entire app and reinstalling on the iPhone. Same behavior in every case. I’ve also tried verifying and repairing the database on the DTPO side. No change.

Any suggestions?

Are your two devices connected to the network the same way? Firewalls? Anything else that makes them different?

No differences as far as I can tell—the iPhone and iPad are connected to the same network (a Time Capsule), to which my Mac is also connected.

Your post suggests that this is a hit and miss kind of problem. I can’t synch on either my ipad or my iphone. That you can synch on one and not the other suggests some great instability in this product, I mean it’s not like you are using devices from different manufacturers. The beauty of Apple is that all hardware is from the same source, so why would it work on one device and not another? I could understand this if you had a PC from Asus and a tablet from Samsung and an Android phone, but you are using all Apple stuff with the same IOS. SO why would it be so complicated?

We are using a well-known third-party network stack for the actual Bonjour code. Nothing we add or modify. And still, some people simply don’t “see” other Macs. It could be device IDs, Bonjour identifications, … even with hardware from the same manufacturer there are differences.

Example: I never had any problems connecting to my Telekom-branded router with any of my iPhones, iPods, or Macs. With the iPad: only troubles until I disabled 802.N-type networking completely. It was flaky, constant network drops, but now it works.

But, as pointed out in other places: We have a working copy of a Mac-to-Mac sync module that will, as soon as it final, replace the buggy sync methods currently in DEVONthink To Go.

The thing is, DTTG on my iPhone can see my Mac just fine. And syncing does begin—I do get a progress indicator in DEVONthink Pro Office. It’s just that it never makes any progress UNLESS I’m only syncing my Global Inbox. It’s frustrating, because DTTG is currently unusable on my iPhone, but prior to the 1.1 update it worked fine.

Hmm, have you, maybe, by any chance, the old plugin installed in ~/Library/Application Support/DEVONthink Pro 2/Plugins? If yes, remove it. DEVONthink will then pick up the built-in one which is required for DEVONthink To Go 1.1.

Sorry, no, that folder is empty. Alas!

OK I got rid of the plugins, the ipad asked to reset synch and then it showed the synch bar for one second and disappeared and nothing got synched

Joe, try creating a local WiFi network on your Mac. To do that, in your Mac’s menubar click on the network icon (WiFi) and choose ‘Create Network’. That will create a network with your Mac’s Name, not connected to the Internet.

In Settings on your iOS device select the new network and try Sync in DT TG. If that doesn’t work, try the additional step of temporarily disabling the Mac’s firewall, in System Preferences.

That suggestion has worked for a number of users who had Sync problems.

Hi Bill, I have tried creating a network and my firewall is off, and still not able to synch. Will be interesting to see if it works for Joe.
Can you suggest anything else, I would really love to use DT on the iPad, I have a lot of PDFs that I could use at the office, where I do not have a mac
As well how close are you to a different synching system, is days or months?
Finally could I get in on the beta testing?
Dr Sterling

Hi Bill
As a follow up, everything is syncing great now that I realized that it was only the mobile groups of each database and Global inbox that are supposed to sync. I wrongly assumed that the entire database would sync and had nothing in the mobile sync groups before.
Thank you , I can start using your product with gusto again.
BTW, my ipad works great, but my iphone times out with long PDFs, any idea what the time out limit in terms of megabytes per document might be on the iphone? Is it possible that my iphone is using the phone data channel rather than the WiFi to sync? if so how could I change that?
Dr Sterling

I haven’t synced to my iPhone 3G but instead to my 2010 iPod Touch, because of its Retina display, which is very sharp.

Both my iPad 1 and the Touch have had identical content synced from my MacBook Air, including some fairly large PDFs, and in both cases sync goes smoothly to completion.

Recently I had a Support query with three JPEG files attached. The issue, which I confirmed, was that the sync stalled on the first of these JPEGs reached during sync. When that JPEG was removed from the content to be synced, and Sync started anew it continued to the next such JPEG. Note that when the sync stalls, the problem file is easily identified in the progress window on the Mac.

This problem was not an issue with JPEGs in general, but with those 3 specific files. I found that if I opened them in GraphicConverter and saved a copy as JPEG, then imported those copies into my Mac’s database, the JPEGs synced to the iPad with no problem. Sync is incremental, so files previously sent to the iOS device don’t have to be resent.

So a ‘strange’ or malformed file can stop sync.

What model is your iPhone, and which version of iOS is it running?

im using iPhone4 and the latest IOS 4.3 i think
I have two very large 5.4 meg pdf+text files. On my iPod 1 they both load no problem, but on iphone, one will load but the sync times out before the second one loads.
this is not a deal breaker for me, as i would not be able to read this even on the retina display, the font is too tiny.
with respect to text created on IOS always going to Global Inbox, is that normal behaviour? Iv’e noticed that the box that pops up to chose the type of document to create says it will be created in the inbox, just not if it’s the Global one or the inbox for that database.

There is only one Inbox in DEVONthink To Go, the Global Inbox, and that inbox syncs to the Global Inbox on the Mac. Creating Global Inbox items in DTTG is accomplished by clicking on the icon with ‘+’ inside a tray. There is no option for creating a document that syncs back to the inbox of a user-defined database. You create documents in a database by clicking on the plain ‘+’ icon and the document will be created in the database group that you are currently viewing (this applies to the Global Inbox as well).

In other words, if the box that pops up says that the item will be created in the Inbox, it will appear in the Global Inbox. If the box that pops up says ‘Create New Item’, the document will be created in the current group you are viewing in the synced database.

Thank you Greg, that really clarified it for me.
Well, now everything seems to work perfectly, thanks guys.
Dr Sterling

I have a similar problem to Joe Kissell.

Sync timeout with DTTG 1.1 on my iPhone 4 (4.3.3).

I did get the DEVONthink Database to sync by it’s self, but the global inbox won’t sync for me. It hangs on contents.xml everytime.

However, sync works fine on my iPad 2 (4.3.3) - Both the global inbox, and the database.

So, it’s useable for me, but I would like the global inbox to sync to. Of course.

I checked the plugins folder in my home directory, and there wasn’t anything there to delete.

Is contents.xml something you could send to us at If not, how large is that file?

Also feel free to contact via the support email for more guided troubleshooting.

I fixed it. I deleted the contents.xml file, and a couple of jpegs that were there too. Then I was able to sync the global inbox.

I don’t remember creating the contents.xml file. It was very small. The jpegs were a few megs each.

Anyway, everything works now.


I just installed the DTTG 1.1 update and it still has connection problems. My netgear modem (DGN2000) doesn’t seem to have an option to disable 802.N (not that I want to disable 802.N encryption permanently anyway), so should I just wait for the update that syncs Mac-to-Mac? I’m presuming this means using the standard USB cable used for syncing with other apps?