Synch an Indexed Database to All Devices - suddenly, I can't

Standard opening disclaimer: WHAT A GREAT TOOL - but WHAT A FRUSTRATING TOOL. :slight_smile:

I already have multiple databases located on my desktop iMac available to me on my iOS devices and MacBook, so I know I’m capable of doing this. In this case, I’m stymied, however.

Here we go…

  • I created a new INDEXED DATABASE on my desktop iMac to help me keep track of archived material stored on an external hard drive. The database is on my iMac desktop DEVONthink app, working very nicely.

  • The indexed database is complete, and stored right where I put my other successfully-synched databases:
    Macintosh HD > Users > [username] > Databases > {name of database]

  • The other databases in this location are synced nicely across all devices.

  • I’m using iCloud (CloudKit)

  • After seeing instructions elsewhere on this site, I enabled BONJOUR in my Sync. No effect thus far.

  • On my MacBook, in DevonThink Preferences, the list under SYNC>iCloud (CloudKit), there is a list of my databases under “LOCAL,” as well as a list under “REMOTE” - - though I have these stored in the same location on my desktop iMac (Macintosh HD > Users > [username] > Databases > {name of database])

  • The new INDEXED DATABASE I made is NOT in the list above on my MacBook, and the INDEXED DATABASE does not appear on any of my remote iOS devices.

I know it’s probably something simple - what have I done wrong that is making it impossible for me to see my new INDEXED DATABASE on my remote devices?

Thanks in advance…

Did you enable the database in Preferences > Sync after selecting the sync location? Otherwise it’s not uploaded/synchronized with other devices.

1 Like

A few initial ideas:

  • is the new database open when you do the following? If not, open it.

  • do things improve if on your Mac, you click on the “refresh” button on the Sync Preferences pages. Makes it appear in local? If yes, then you need to check it “on” to make available for sync via CloudKit

  • You have Bonjour enabled (accepting “incoming connections”) only on the Mac and not enabled on the other devices?

  • You are aware (from other posts here) that for some the Apple Cloud sync services are sometimes unreliable?

1 Like

Yes, I did - it is “checked” along with the others that are successfully syncing.

  • Database open

  • I hit “refresh.” No change. Checks are “on” for the databases I use successfully, as well as the new indexed database that is not synching.

  • I have heard some rumbles about Apple Cloud sync services, but am hesitant to move to Dropbox, for instance, while iCloud is working for the other databases.

QUESTION: Can I have this single database located and synced in DROPBOX while leaving the rest in iCloud (CloudKit)?

In other words, can there be multiple means of syncing at work at the same time for different databases?

You can’t put the actual database in any cloud-synced location.
However, yes you can sync one database to one sync location and sync another database to another sync location.

What is reported in DEVONthink’s Window > Log?

First, don’t put any of the database on a sync folder. If you have that, it’s not gonna work and probably will break a lot of stuff. If that is what you have done, don’t. Move to the local drive.

Oh, I now understand that the new database is showing up on the Local list but is not synching. I previously erroneously understood it to be missing from the Locals list. On the Mac, for the Apple CloudKit sync location, check for that database the “Last Synchoronisation” date/time and compare. I’m guessing it was copied up to the sync location (unless Apple’s CloudKit is mis-behaving).

On the other devices, for the Apple CloudKit sync location check that sync is turned on.

Get Bonjour working. Details in the DEVONthink Manual with supplementary info at Bonjour Simplified

Yes, you can have multiple sync locations. If this were not possible, then DEVONthink would have disabled additional locations. :wink: But, for a database, only use one sync location at a time.

There is actually nothing in the DEVONthink Window > Log mentioning my unsynced database. Just normal/routine messages regarding my other databases.

Just to be clear: I can - while still keeping the current iCloud databases synched - drop this particular database into my Dropbox and choose “Dropbox” in the DEVONthink Sync preference panel?

I was feeling revved and ready to try, until I saw the instructions on this particular page:

That seems pretty daunting - - is it accurate?

Do not do that. DEVONthink database are not to be stored in Cloud sync locations. Your databases will probably get corrupted by those sync services and if you don’t have backups. Poof. Gone.

At this point you are mis understanding synching, I think. Please re-read how to setup synching in the DEVONthink Manual.

I did not click on the link you provided. Who knows if this site is any good? Use the DEVONthink Manual.

I don’t blame you for skipping the click. :slight_smile:

I’ll go re-read the Manual - I may have been a bit “thick” when I re-read it earlier. However, I honestly feel as though I simply duplicated the steps I’ve previously taken. I’m having trouble seeing the logic.

Forging forward …

This is a new thing I noticed:

Whereas all of my databases in the iCloud section under SYNC (in preferences) say something to the effect of “Last synchronization: Today at 12:27:06 PM” beneath the name of the database, the problematic database says “Not yet synchronized, upload database”

There are four buttons below the list:
Screen Shot 2022-10-06 at 12.35.57 PM

They say (left to right)-

  • Import database

  • Synchronize database

  • Refresh list of databases

  • A gear with a list below
    -Screen Shot 2022-10-06 at 12.34.22 PM

I activated all the logical buttons - nothing changed.

Again NEVER put your databases in ANY cloud-synced location.

  • Post a screen capture of the Sync preferences with the sync location selected.
  • Do a File > Verify & Repair on the problematic database. What is shown in the Log window?

PS: Yes, those instructions are essentially still accurate but it’s not complicated.

Here is what the database in question looks like, under LOCAL (note “not yet synchronized”):
Screen Shot 2022-10-07 at 12.27.21 PM

I did a right-click and chose “synchronize database” to no avail.

It’s big - 8.33 gb - only an INDEX database, however. I was assuming it’s a loooong upload.

Screen Shot 2022-10-07 at 12.28.41 PM

You didn’t answer this…

Oops - sorry about that.

Running that now - looks like it’ll take a while. I have the “spinning beachball” and the blue line seems to be standing still. I’m going to check back in about 20 minutes to see if it progresses beyond the “G”…

Screen Shot 2022-10-07 at 5.06.31 PM

OK - took a long time, and then it said it “needed repair.” I hit the “repair” button, it went through some itemized issues - and this message appeared:

Screen Shot 2022-10-07 at 6.54.57 PM

To avoid repeating advice, see page 191 of the outstanding “DEVONthink Manual” (3.8.6 version) in the section "TROUBLESHOOTING’, subsection “Repairing a Defective Database”, the steps after “Verify and Repair”.

Also, I’m wonder if having this database on an attached USB drive has anything to do with this. Dunno. Is the hardware (cable, disk, etc.) ok?

1 Like

No worries!
The Log window should show more info.

A thing that comes up quite a bit in the Log Window is:

The number of “issues left” decreases as the log progresses, from “11 issues” to “4 issues.”

The latest is this:

“Repair the database” has not worked.

Again, on the positive side, I have a very useful Database Index right here on my “home machine.” It’s just not getting synced so I can access it remotely.

I will, as per rmschne, see page 191 of the outstanding “DEVONthink Manual” (3.8.6 version). Good advice (I think it might be smart to review every couple years).

GOOD CALL on being specific about the version number.

My Kindle app mistakenly recognized my older copy of the manual as a duplicate and wouldn’t allow me to add the 3.8.6 updated version until I ditched my older one.

Thanks for the heads up!