Synchronisierung friert ein

Hallo,

nach Jahren des halbherzigen Benutzens will ich jetzt endlich wirklich papierlos werden :smiley:. Dazu habe ich fĂŒr meine Datenbanken eine Synchronisierung zu einem externen WebDAV-Server aufgesetzt (Apache Webserver mit mod_dav2).

WĂ€hrend der Synchronisierung bleibt der Balken irgendwann einfach stehen. Keine Fehlermeldung, kein Eintrag im Logfile. Es steht auch jedesmal ein anderer Dokumentenname in der Fortschrittsbox.

Wenn ich die Synchronisierung dann mit dem X beende, steht im Protokoll nur “Der Vorgang wurde abgebrochen”. Der Punkt “Synchronisieren” im KontextmenĂŒ der Datenbank ist dann aber ausgegraut bis zum nĂ€chsten Start des Programms.

Ich bin ein bisschen ratlos, an welchen Schrauben ich drehen könnte, um das in den Griff zu bekommen


Viele GrĂŒsse, Tobi

Ist denn die Synchronisierung wirklich eingefroren, d.h. DEVONthink tatsĂ€chlich inaktiv? Sie könnten z.B. per Dienstprogramme > AktivitĂ€tsanzeige.app die CPU/Netzwerk-Nutzung ĂŒberprĂŒfen.

Wo liegt die Datenbank die Du synchronisieren willst? Lokal?
Was ist das fĂŒr ein “GerĂ€t” auf das Du per WebDAV synchronisieren willst, ein NAS?

Drei andere DT-Datenbanken liessen sich btw. problemlos synchronisieren. Eine weitere blieb einmal so hÀngen wie diese und lief dann aber beim nÀchsten Versuch durch.

@cgrunenberg: Die CPU-Anzeige ist relativ konstant um die 100%(±1) / 8 Threads auf einer 4-Kernmaschine.

@sneezr: Die Datenbank liegt auf meiner lokalen Festplatte.
Das ZielgerÀt ist ein FreeBSD-Rechner mit ZFS im LAN, ganz normaler Vanilla Apache 2.2.29 mit mod_dav2.

Funktioniert es denn evtl. nach Löschen des Sync Stores auf dem WebDAV-Server sowie Löschen des Ordners ~/Library/Application Support/DEVONthink Pro 2/Sync und anschließendem Anlegen eines neuen Sync Stores wieder?

Hi,

sorry fĂŒr die lange Pause, war jetzt 2 Wochen unterwegs


Auch nach dem Löschen auf dem WebDAV Server und lokal (Sync Verzeichnis) habe ich den selben Effekt: Die Synchronisierung friert ein, die CPU bei ca. 100%.

Allerdings habe ich entdeckt, dass ich die DT-Datenbank nicht lokal habe, sondern auf einem AFS-Share im Netzwerk, da hat mich wohl meine Erinnerung getÀuscht. Ich habe jetzt alle Datenbanken auf den lokalen Rechner umgezogen und jetzt geht alles. :smiley: Vielen Dank!

Spannend wĂ€re allerdings natĂŒrlich nach wie vor, was das Problem mit einem gemounteten Verzeichnis ist, oder ist das schon bekannt?

Erleichtert, Tobi

Wie schnell war denn die Anbindung zu dem Netzwerkvolume? Wirklich empfehlenswert ist das eigentlich nur mit mind. Gigabit-Ethernet.

Gigabit geswitcht, die Leitung wird normal problemlos gesÀttigt, also das sollte passen.

Mal so ins Blaue spekuliert (ich kenn mich mit Entwicklung unter OSX leider nicht aus
): Vielleicht versucht er irgendwas zu locken, was ĂŒber AFP nicht geht und versucht dann in nem Loop immerwieder einen Lock zu bekommen oder so, daher die 100%?

Zumindest DEVONthink selbst sollte so etwas nicht machen. Hilfreich wĂ€re vielleicht eine Analyse, falls das erneut passieren sollte. Dazu mĂŒssten Sie


  1. Das Programm Dienstprogramme > AktivitÀtsanzeige.app starten
  2. DEVONthink in der List der Prozesse auswÀhlen
  3. Den MenĂŒpunkt Darstellung > Prozess analysieren auswĂ€hlen


und uns die Analyse senden. Danke!