Syncing inboxes after restore

Hi all,

I recently restored my MacBook hard drive, but the backup is from several weeks ago. Since that time, I’ve saved a number of things in my inbox, which are showing up in DDTG but not DT3. Any ideas on how to get things syncing up again? I am using Bonjour.

(Side note that is probably irrelevant. I used to use Dropbox to sync, and I had that location checked in DTTG. As I was fiddling with sync, I went ahead and unchecked it. It remains unchecked in DT3.)

It would probably be helpful if you posted screenshots of your settings.

Sorry, here’s a screenshot of the sync window. Please let me know if anything else would be helpful. Thanks!

Oh and here’s DDTG
Uploading: 4D0C8D60-3AFB-436B-9942-90CD29B325BD.jpeg…

Which sync location did you use in the past? Did your backup restore any information in the folder ~/Library/Application Support/DEVONthink 3/Cloudy?

  • Why is the sync location in DEVONthink disabled?
  • Isn’t DEVONthink To Go syncing to it?

I’m not sure… I had it configured for Bonjour, but I’m not sure which sync location was checked. I’m guessing it should be “Local Sync Store”? If so, I’m not sure whether it became unchecked after restoring or I accidentally did that myself.

Yes, there’s information in that folder, screenshotted below.

Is it “Local Sync Store” that should be checked for Bonjour? If so, it must have come unchecked somehow, maybe in the restore or I did it accidentally myself. I can try checking that to see if it resolves the issue.

You said you were syncing with Dropbox.
And there is a disabled Dropbox sync location named Library in DEVONthink.

Is DEVONthink To Go syncing with that sync location?

Yes previously I was syncing to Dropbox, but then I had some issues with it, and you advised to just use Bonjour instead :slight_smile: So, Bonjour is what I’ve been using for the past six months or so. But it looks like while I had disabled the Dropbox sync on DT3, I hadn’t done it on DTTG. That’s been done now though.

What I think you have done is to activate Bonjour on both devices, but you have not connected either device to the other.

You have activated Bonjour on the iOS device; that is showing up as mobile@iphone on your Mac. Rather than activating Bonjour on the Mac, you need to select mobile@iphone Local Network - in the window on the right you will then be able to select the databases you want to sync. Alternately turn off Bonjour on the iOS device and and select the appropriate Local Network under “Locations” on the iOS device. If you are intending to sync more than 2 devices with one another, then that would probably be the more typical way of going about things. (The device with Bonjour turned on is the server, the devices accessing the Local Network are the clients.)

Thank you so much for this very careful answer. I’m going to try this as soon as I get home.

One more thing: While I was waiting for responses, I tried something else, and I redid my Dropbox sync, which is working perfectly now (Inbox is now synced up across DT3 and DTTG!). Would it be useful to add the Bonjour sync, or will have two different syncs make things weird?

1 Like

Bonjour and Dropbox sync can be set up and used in parallel. Bonjour will probably be noticeably faster (and so might be advantageous if you want to sync quickly before leaving the house, for example; obviously there often won’t be much difference if there isn’t much to sync). It is also more private, in that your data does not leave your network. As such, I sync all my databases via Bonjour, and a select few additionally via a cloud service.

Wonderful, thanks so much for all your help!

1 Like