Tables Not Appearing Though Present. (invisible lines I think.)

I discovered that tables are not appearing in RTF documents on my iMac Pro (Intel). I see them fine on my MacBook Pro (M1 Max). Both computers are running DEVONthink 3.8.3.

I uninstalled then reinstalled DEVONthink on the iMac and got the same result. Is there some fix for this? I have no idea why this is happening on only one of my machines.

Thank you,


Which macOS versions do you use on these computers? And light or dark mode? An example document would be useful.

Monterey Version 12.4 on both Macs

I uploaded two screenshots. One with the same RTF file with two tables from DEVONthink and the second from Pages showing the tables created in DEVONthink but not showing in DEVONthink.

I uploaded the file in zip format.

tables? (1.1 KB)

I’m not seeing any issue with the rich text file you posted, even with subsequent edits…

As I originally posted, I’m not seeing any problems with it either, even on another computer running the same OS and version of DEVONthink. But you see the second screenshot. That’s my iMac Pro. Why does my iMac not show the table? The table still doesn’t appear even after uninstalling and reinstalling the software and several restarts.

Do you have a solution for this? I’ve tried everything I know to try.

No. As I said, I am not seeing an issue here and this is the only report we’ve received.

If you click in the content of the file in DEVONthink and press Command-A, does it select anything?

As the post’s title suggests, I know there’s a table or tables there, but DEVONthink doesn’t show it. Could it have something to do with the table’s attributes? Is it possible that the table lines are white? How do I change the color of the lines from white to black?

BTW, this happens in either light or dark mode.

Thanks for your help with this.

Does that first cell with thick lines tell you anything about the way this installation creates tables?

Just grasping at anything to solve my problem at this point. I’m not a programmer.

I need this feature to work. This is how I would like to create reports for my student’s work so it’s kind of important. I can switch to markdown but it’s a shame to have a feature of the app lost.

I loaded the file in DTTG 3.5 on the iPad. Initially, it appeared as in your screenshot, i.e. with a thick black border in the first table. When I changed the display to full screen by tapping on the double arrow on the top left cell, the top table was reduced to only a single cell, the bottom one has two rows and three columns as before.

Opening another record and then the tables again showed the original display, i.e. thick border and three columns, four rows. Something really seems to be off with this file.

Converting to MD or text results in empty files while converting to a formatted note gives two nicely formatted tables. I dunt know if that’s to be expected, though.

@MaynardGKrebs: how did you create this file? And does it have to be in RTF format or could you also use Pages?

And I would also ask if it could just be a sheet…

Thanks for your help, @chrillek.

I created the RTF file on the iMac (Intel). If I make an RTF file in Pages or Word and report to RTF, it displays normally on the iMac.

Here are three examples:

RTF Table On (991 Bytes)
RTF Table Created on (1.0 KB)
RTF Table Created In (9.5 KB)

If I create it on any version of DEVONthink, either the iPad or my MacBook, the result is the invisible table. Mind you, none of this happens on the MacBook. Everything works perfectly on the MacBook (M1 Max).

The only solution I can find is to create a table in another app and then copy/paste it into the doc when I’m working on the iMac.

I can’t help but wonder if this is somehow related to the fact that the iMac is Intel? I have no idea, but at least I have a workaround. It’s a shame for such a brilliant app for me to have this issue.

I use it for everything now. It’s become a brilliant doc creation app with the new iOS editor. The people at DEVONtechnologies know what they’re doing, and I’m so grateful for this fantastic tool, even with this little glitch—my hat’s off to them.

I’m sorry, I don’t understand, “And I would also ask if it could just be a sheet…”

One final update: If I try to update a table I copy/pasted by using the table tool on the iMac, the table disappears on the iMac.

Table Copy pasted from Word and edited on the iMac - no (1.1 KB)

It’s not that the table is invisible. It’s that the table isn’t there on the iMac.
This is how it displays on the iMac:

The same file as it displays on the MacBook:

One final crazy thing: The table shows up in the THUMBNAIL but not on the full doc display.

Are you just putting a table in an RTF file and filling in the cells, like you would do in Excel or Numbers?


Does it work after booting the computer in safe mode or deleting DEVONthink’s preferences?

At all computers running the same version of macOS? If not, it might be possible that the rtf framework is different, too. Or that Apple simply has a bug in it.

1 Like

If that’s the case, why not use a DEVONthink sheet instead?

That solved it! Thanks. I assumed that uninstalling and reinstalling DEVONthink would reset everything but it didn’t. I just typed

defaults delete com.devon-technologies.think3

Into the terminal and that solved the problem.


1 Like