Tags ..... again

I have excluded groups from tagging in a database.

Document A is in group “CS206”. I then type in a tag for it, “Hashtable”. The document now also appears in the Hashtable tag group. If I hover the mouse over it, the tooltip says “Location: CS206”. The tip says the same thing if I choose the document in the CS206 group.

The user guide says that when I add a tag to a document - “The item is replicated to the Tags group.”

However, when I invoke the Information window for either of the Document A items (in the group or in the tag group) I’m told there are no replicants or duplicates. This seems to contradict what I’ve described above.

If I then delete the document from the tags group, the “copy” in the CS206 group is still there, and vice versa. My questions are:

  1. when a document in a group has a tag assigned to it, and it appears in the appropriate tag group - for the copy in the tag group, what is it? Not a duplicate or replicate?

  2. how do I delete a document in a group and have all its “copies” in whatever tag groups it is in also delete? What’s strange, if I try to delete document A from either the group or tag group, the “delete” option in the “Edit” menu is grayed out. But I can delete it by pressing the delete key or the delete button in the tool bar.

[edit: I’ve tested things again, this time if I delete the document in the group, it also deletes from the tag group - I’d swear that didn’t happen before, but I can’t repeat that, so perhaps I wasn’t paying attention at the time.
Also, I just found the section in the new e-Book that says tagging a doc replicates it, but doesn’t mark at as a replicant. - I guess my questions have been answered.]

Tags in the Tags group (“ordinary” tags) are also replicants but they’re not displayed that way and therefore not listed in the Instances pop-up menu of the Info panel. This has been requested by our users/testers.

I had a similar problem recently with the tags and get many unreal replicant (copies of same file) in a tag (when I choose replicate to -> (the tag I want the file to) and if you already have tagged this files before with the same tag, you get a one more copy of these files in the tag (unreal replicant) and like Christian said before, these unreal replicants doesn’t show up if you search after them in a smartgroup for instance replicant.

The solution to get rid of these unreal replicants is to rebuild the whole database. But take an backup of your database file first before you rebuild just to be on the safe side.

:wink: