Tags and Duplicates

I use a lot of tags in one of my databases so I can browse the material more efficiently. These are text files containing a combination of jpg images and text. I wanted to sort some files I was interested in into temporary folders for a project so decided to Duplicate them.

I opened TagView, selected a file and Control clicked on Duplicate To. It correctly put a copy of the file in the folder I selected – but it also duplicated the contents within the file! In other words, when I scrolled down inside the files, I discovered there was now a second set of everything below the original material.

I don’t know whether this is because you can’t Duplicate or Replicate from within TagView, or whether something is corrupted in my database.

Anybody have an idea what is going on here?

Second post, hard on the first. Just discovered it is duplicating everything within the file when I duplicate from any View – not just when I am in TagView.

Something definitely strange here.

  • Edited to remove original question as korm’s reply clears this part up.

Also I have a suggestion when working with some documents on a temporary basis for a project. You might find that replicating the documents instead of duplicating them a better way to go. Then you can modify the documents if needed and the changes will appear in all occurrences of the documents. Duplication works well when using the document as a template, or when you need to track revisions made to a document over time.

Are these RTF files (I assume since they contain “jpg images and text” that they are)?

I’ve attempted the same procedures you describe, using RTFs with text and images. I get duplicated files, but not duplicated content. AFAIK, I’ve never seen duplicated content when Duplicate is used.

I second Greg’s suggestion to use replicants.

I understand difference between Replicants/Duplicates. The content is duplicated no matter which one I use.

Since I posted I ran Verify and Repair; no problems. Rebuilt the database, but that didn’t change anything.

I figured out a temporary work-around – I created a special tag that sorts the material the way I wanted to and I can look at it that way.

However, that doesn’t fix the problem – I can’t use Replicant/Duplicate the way it is working now; seems a bit crazy.

Content is duplicated even with replication?

It’s not easy on the forum to diagnose a file problem when we don’t have the same files. So I’d suggest opening a ticket with Support and sending them sample files, if possible.

Yes, content is duplicated with both Replicant and Duplicate commands… Other problems in this db, – see my post re Invalid Duplicates…

I will send sample file to support later today.

I have had problems with other databases lately - finding errors with V&R etc. Had one get so unstable i feared losses, especially when I opened several backups and found problems. I exported everything and abandoned the db entirely. Have not yet faced the chore of creating a new one.

Is it possible the app is corrupted in some way? Reinstall?


Where are these databases located? Are they in a Dropbox folder?

Have you rebooted your machine?

DBs are on single internal drive, backed up to external drive; no Dropbox, no sync with anything.

Did reboot and it has helped, but still something odd.

First two times I tested a Replicate and then a Duplicate (one each), it copied part of the content of the file instead of all of it, and with each reiteration it added a different portion of the contents below the original material.

Tried again and it seemed to have recovered its wits – like “Oh, wait a minute, that’s not what I was supposed to do,” and on the next tests (two each of Replicate, two of Duplicate), it no longer added content.

However, while I get a Replicant icon next to the filenames, there is no Duplicate icon, and those files do not show up in the Duplicate Smart Folder.

I closed the db, Quit DTPro, reopened, etc.; still the same. I had already done a Rebuild. I had 2.5.2; upgraded to 2.6; no change. Did another Rebuild; no change.

Next step? I don’t know whether to export everything and create a new db, or download the entire app again (instead of just an upgrade) and start over?. This instability is making me very nervous – these files are Imported, not Indexed.


The behavior you describe, creating more than one copy of all or part of the document content within a duplicated document, is anomalous. I’ve been using DEVONthink for 11 years and that has never occurred for me.

Could you please send to Support copies of a document before and after duplication, that shows that behavior. The easiest way to attach them to a Support message is to export them to a Finder folder, then compress (zip) the folder and attach the zipped file.

Hi Bill

Well, it hasn’t been 11 years, but I’ve been using DT for a very long time, and I agree what I am seeing is an anomaly.

Just tried it again, and this time it behaved – no internal duplication, file appeared in destination folder and both are in Duplicates Smart Folder, icons on both. Go figure.

But since I have no idea why it didn’t behave, or why it now is, I am still nervous that something is wrong, particularly since other weird things have happened in the past week or so. So I’m attaching a copy of a file that has internal duplication; the destination file was normal, but neither have an icon and neither appear in the Smart Folder. Please confirm receipt.
V4136 Skirt.rtfd.zip (873 KB)

PS: I initiated a different topic a few days ago that now seems related to the one we are discussing here; please see Invalid Duplicates, 7/23. Same db.

I imported that file into a database. In DEVONthink, the document has a normal RTFD icon. Yes, I see that the content is ‘doubled’.

How did you perform duplication of the original file? By Data > Duplicate of the selected original? By selecting the original, right-click and choice of the contextual menu option, Data > Duplicate To?

Selected the file, used Control key to drop the Context Menu and chose Duplicate To

Try this with a mouse or a trackpad right-click if possible and I bet it won’t happen.

You are for sure running 2.6?


Am i missing something here? On a Mac Air and never use a mouse. Mouse Right click = Control key. Both drop context menu, right?

Was at 2.5.2, upgraded to 2.6. Not happening now but wish I knew whether it was app or something in this db. Have several others and will open them to chi for similar problems later tonight. Will report back

The functionality between right-click and Control-click is the same but the mechanism is different. If you two finger click on the trackpad to bring up the context menu, the problem shouldn’t happen. Does it?

There was an issue we thought we finally had resolved. What view are you in when you control-click (split pane, list, etc)?

Had problem in TagView and SplitView.
Don’t normally use 2-finger click but could try it
But seems pretty fussy to have to only work one way.

So well into the wee hours last night, I went through all my DBs to check for any other anomalies. Most were OK, but two of them also had false duplicates (not the DBs I originally had a problem with).

I tested the Duplicate To command in both of them (and this time used the two finger click to drop the context menu, as suggested).

In the first db, the command worked as it should – the file was duplicated, the new one appeared in the designated folder, and they both showed up in Duplicate Smart Folder. The content was not duplicated. The original false duplicates are still there.

In the second db, the command didn’t behave. In this case, the file was duplicated, the new one appeared in the designated folder, the content was not duplicated – but neither of them had a duplicate icon, and neither of them showed up in the Duplicate Smart Folder. The original false duplicates are still there.

I did V&R on all of them, and no problems seen; I made new backups.

This keeps getting weirder all the time. There are now anomalies in three entirely separate DBs, all related to the Duplicate function – false duplicates, duplicated content, duplicates that don’t show up in the smart folder. This suggests a problem in the app, not corruption in my files.

And as I said, this is imported content, not indexed, so this is making me a bit nervous. While I’m not afraid of losing data because there are redundant copies, having to abandon a db and redo it is a major waste of time. Any new ideas?

  1. Does this problem occur on another Account on the same machine?

  2. Have you done any maintenance checks on your machine? TechTool, DiskWarrior, or even Disk Utility, etc. There are times when inexplicable, sporadic issues have occurred before hardware failures.

  3. Do you have the same issues after quitting DT, moving ~/Library/Preferences/com.devon-technologies.thinkpro2.plist to your desktop and relaunching DT?