Tags behaviour in DTTG & it’s URL scheme

A couple of questions:

  1. Why do tags show up like a Folder in Files.app?

  2. Browse to any file under a Tag group. Now drag it out to any folder, like Inbox. The file loses its tag. If I drag it to another tag group, it sheds its previous tag, and takes on the new tag. So, basically, tag groups are being treated as Folders in iOS by DTTG itself. That’s not ideal behaviour.

  3. What’s the URL scheme for adding tags in iOS? I tried the following with Workflow.app, but it doesn’t work. It accepts the Title and the Comment values, but not the Tag values:

x-devonthink://x-callback-url/createImage?source=Base64 Encoded&title=Title&tags=TagText&comment=Comment


Because Tags are a group in a DEVONthink database.

It is the exact expected behavior in DTTG2 itself, therefore the same would follow suit in Files.app.

I have already replied in your other post, this is a bug that has been filed.

Unfortunately, didn’t find the TAGS bug fixed in the recent 2.4 update :frowning:

Any tentative date for that fix?


It wasn’t scheduled for the 2.4 release, and sorry but no, I can’t give you a timeframe. As a company policy, we don’t issue release dates.

It appears adding tags via URL scheme was fixed in 2.4.1 (at least according to the release notes), but it looks like it’s not working for me again in 2.4.4. Anyone else?

Working as expected here. What’s your URL?

Here’s an example

x-devonthink://x-callback-url/createwebarchive?title=User Forum — DEVONtechnologies • View topic - Tags behaviour in DTTG & it’s URL scheme&location=https://discourse.devontechnologies.com/t/tags-behaviour-in-dttg-it-s-url-scheme/23172/6

[I should have added: in my use case, these URLs are called from Workflow on iOS]

If I have DTTG showing Recently Modified before I run the workflow that generates this call, then I can see the new note appear at the top of the listing -with tag- but after the workflow ends (it returns title and item link to me) the entry no longer has a tag when I next switch to the DTTG app. Happening on iPhone and iPad…

and a simpler example. If I paste this into Safari on iOS, a new note gets created in the right place (my Inbox), has the right comment, right content, but is missing its tag


any further insights on this? Anything I can adjust, or shall I watch future releases for a change? thanks.


Please wait for the next release. I’m not seeing an issue with the current intrnal build. Thank you for your patience and understanding.