Tags overload


I added a few RSS feeds to my database and within a few days I had over 5000 tags which made it hard to see the tags that I had added. I’ve read through the posts on the board and the advice is to switch off tags for the RSS feed but I can’t see how to do this?

If I select a feed and open the info panel I can see that it has a section to exclude it from Classification, Search, See Also and Tagging, my problem is that the Tagging option is dimmed so I can’t do anything with it.

I tried putting a new feed in a group, I can select the group and exclude it from Tagging but it has no effect on the enclosed RSS feed.

I eventually deleted the feeds and spent ages selecting the empty tags and manually deleting them from the database.

Is there any way to exclude an RSS feed from being tagged?

And if you have several thousand unused tags is there a way to purge them?

Many thanks, Alan

Go into ‘Preferences>RSS’ and uncheck ‘Convert categories to tags’.

Go into the Tag view, right-click in the tag column, and select ‘Sort>By size’. All your empty tags should appear together.

Hi Greg,

Thanks for the tips, the RSS preference works just fine but sorting the tags by size doesn’t group the empty ones together. It does change the sort order but I don’t understand the order it has them in.

Regards Alan

Just to confirm, you want to click in the tag pane to sort the tags, not the contents in the file list pane. Sorting tags by size in ascending order should put all the empty tags at the top of the list. The ‘size’ used in this calculation is the aggregate of the size of all documents in the tag group. As an empty tag group’s size returns a null value, they should all be grouped together.

Hi Greg,

I was sorting the tags and what you’re saying makes sense but it isn’t doing as you suggest here.

Regards Alan

Curious. What happens if you:

a) Switch to Three Pane view
b) Double-click the Tags group to focus it in a new window
c) Right-click in the tags pane and select sort by size

Any difference there? Doing the above again gives me the tags sorted with all empty tags at the top. If that does not work, I’m at a loss to suggest anything else.

Hi Greg,

Thanks for your efforts, that has sorted the empty tags to the top this time. I’ve noticed though that the sort isn’t correct, even on your example:

Some of the items are out of order, I’m wondering whether it has something to do with the issues I’m seeing? As you can see the empty tags have come to the top:

That isn’t the case for the items further down:

It’s not as though there are two levels of sort applied either, maybe this is one to show DT?

Regards Alan

Actually that looks correct. The list is sorting on the total size of the items contained in each tag. So a tag containing one document that is 100 KB in size would appear below a tag that contained 10 documents, each 9 KB in size.

Hi Greg,

Thanks, that makes sense, the tags display the count of the items contained but you can sort them by the total size of the items contained.

Regards Alan

It really seems as though “convert categories to tags” should be unchecked by default. This can really overwhelm a carefully-tailored tags structure.

1 Like

To easily get rid of empty tags you could either sort the tags descending by size or create a smart group with the conditions…

Item does not contain Data
Kind is Group