"Take rich/plain note" services have stopped working

The services “DEVONthink: Take Rich Note” and “DEVONthink: Take Plain Note” stopped working for me recently. Nothing happens when I use them, except the applications from which I try to turn selected text into notes in DEVONthink Personal slow down for a while. I have tried using the services from Safari and TextEdit.

What caused them to stop working and how can I get them working again?

The only changes that I recall making on my computer were Apple’s software updates. I think the only update was Java (the first security update). I applied the second Java security update today. The problem remains.

Do these services use Java? Could the security updates have broken the services? If not, what?

(I prefer using the services because they work with selected text in Safari Reader, allowing me to turn just articles into DEVONthink notes very easily. The “Clip to DEVONthink” extension does not work as well.)

Thanks for any help.

Those Services work here, after installing the Java security updates.

A couple of things to try when something goes flaky are: Click on the DEVONthink app name in the menubar and choose “Empty Cache” (to clear a possibly stuck cache); and then Restart the computer (to clear any “cobwebs” in memory).

Does, e.g., the keyboard shortcut for the Service to capture a selected area of a Web page as rich text work, now?

If not, click on the app name in the menubar, choose Services, and then Services Preferences. If the check box for the desired Service isn’t checked, check it to activate that Service. If Services Preferences displays a yellow alert triangle, the keyboard command for that Service has been “hijacked” by another app or by the user’s choice of that keyboard shortcut for another purpose.

Thanks for the response.

Clearing the cache did not help.

The keyboard shortcut produces the same result: no clipping, and the application from which I’m trying to clip slows down for a while.

The services are active and have been active. I always use right-click to access them. They have always appeared in the contextual menu.

Other ideas?

If the Service is active and there’s not w triangle warning of a conflict for the keyboard shortcut, I suspect an error in making the call to OS X.

Did you try a Restart? If so, try an OS X maintenance utility such as OnyX or C0cktail, to clear caches and perform other preventive maintenance functions on the operating system. Be sure that the version of the utility is appropriate for your version of OS X.

I let Onyx do all its maintenance tasks and re-started my computer. I tested the services in TextEdit to avoid problems that might come from Safari’s plug-ins or extensions or something else. The problem remains.

iMac, 4 GB RAM, OS X 10.7.3, DEVONthink Personal 2.3.3

Any other ideas? Conflicts with DEVONsphere Express? DropBox? Those are my only start-up items. Would re-installing DEVONthink make any difference?

Thanks for your help.


Select some text, e.g., in a Safari page. Control-click on the selection. In the contextual menu, click on “Services”. A list of the applicable active Services will be displayed. Is the Service to capture as rich text displayed? If so, click on it and the capture should be performed.

If that works from the contextual menu environment, something has taken over the keyboard shortcut.

If the option to capture as rich text wasn’t displayed, the Service isn’t active on your computer. If you recently upgraded DEVONthink, perhaps the download and installation was incomplete or damaged. Try this: quit the Sorter, quit the DEVONthink application, move the DEVONthink to the Trash, then download and install a fresh copy of the DEVONthink application.

I have always used the contextual menu, not the keyboard shortcut. The services have always been available in the contextual menu and they still are available. They just do not work anymore. Nothing happens, except the application from which I am trying to clip text slows down for a while.

As you suggested, I deleted DEVONthink Personal, downloaded a new copy from the DEVON Technologies site, and put it in my applications folder. Now, when I try to use the “Take plain note” service, this message appears:

The action “Run Shell Script” encountered an error. Check the action’s properties and try running the workflow again.

I re-installed Lion. The “take rich/plain note” services are working again.

Two days later, the services have stopped working again. Now, using the right-click contextual menu to take a rich note from Safari in Reader mode opens DEVONthink Personal Edition, but does not create a note. Attempts to take a plain note from TextEdit do not work either.

That’s not normal behavior.

Have you installed a utility that modifies the appearance or a behavior of OS X so as to hack the operating system and cause errors?

What happens if you create and run from a Guest account? If the computer behaves properly, that implies that something installed in your normal user account is causing errors.

I cannot log in with the guest account because it seems to require a password even though it is not supposed to. But I created a new account and logged in as the new user. The services worked fine.

So I’m looking for everything in my account that could interfere with the services, and I can’t find anything. My only log-in item was DropBox, which I removed. I use StartNinja to turn off the start-up chime, but I don’t think that runs at start-up anyway. It only changes a system setting, which I changed back to the default (let the start-up chime play). I turned off DNScrypt and remove it from the menu bar. I had already stopped DEVONsphere Express from loading at start-up. I removed the Glimmer Blocker preference pane and the MySQL start-up pane, neither of which had not been active anyway. I’ve checked for any commands that I have given through Terminal recently to change system settings (I keep a list in DEVONthink so I can reverse the settings if necessary), but did not find any.

I tested the services from Safari and TextEdit. These changes did not solve the problem. When I try to use the services, the initiating application is busy for a while, and DEVONthink Personal is opened, but no note is taken.

I have put some text on the OS X start-up screen. I doubt that such text would interfere with the services.

Then I deleted DEVONthink Personal, moved all DEVONtechnologies preference files out of ~/library/preferences, and downloaded and re-installed DEVONthink Personal. It is noticeably faster than my previous installation, especially starting up.

But the services still do not work.

I just re-installed Lion two days ago. The services worked again right after the installation. I am almost certain that I did not make any system changes in the last two days.

I use the services every day. I really want them to work again. Can you think of any specific cause and other actions to try?


If those Services continue to function properly in your new use account, which doesn’t include the utilities you installed in your regular account, I would surmise something installed in the regular user account is causing gremlins.

Can you think of any specific cause and other actions to try?

No. But my bet is that the problem results from something you’ve installed on the computer.

There are utilities that modify the code of OS X in order to add or modify a feature. If the developer of a utility has been sloppy and/or hash/t adequately tested his code, errors may be created in the operating system.

Over the years in Support I’ve seen so many problems that result from “hack” utilities that my philosophy is to avoid them, and to install only those that I’ve tested as both useful and problem-free. I’m suspicious even of those, as they may break and cause problems after the next OS update by Apple. If you have installed utilities such as text expanders, 1PassWord, etc. make certain that you keep them updated after each new version of OS X (I don’t have either of those examples on my Macs) .

Because I install very few items that modify OS X, I miss out on the (often real) conveniences some utilities offer. On the other hand, my computers stay stable, and so I avoid a lot of time and aggravation that might result from a utility that has introduced gremlins to my computers.

There’s no way I could analyze what’s on your computer. In some cases, two utilities might not individually cause operating system errors, but if both are installed, they could interact to cause errors. Hence my general reluctance to install hacks.

The problem occurs in safe mode, which, I think, would rule out system hacks and some other causes. Can you explain why? Or might the problem be caused by something other than system hacks?

This thread has received 184 views. Is anyone else having the problem? Do you have any insights?


Yours is an uncommon problem, as you are accessing the Services by the contextual menu (so the issue of ‘hijacking’ the keyboard shortcut for the Service isn’t relevant).

Unless you have inadvertently unchecked the specific Services in System Preferences > Keyboard - Keyboard Shortcuts - Services, there must be something wonky about your computer. Otherwise the Services, once activated, should continue to work.