text in standard view re-set to colour of full-screen backgr

I have set text colour and backgrounds in editing preferences.

Suddenly the text colour of a plain text document switches to the background colour after I exit from full screen (although it is always correct in full screen)

I think that this has started since changing the preferences in both the main screen of the ‘editing’ section of preferences and also in the font dialogue that opens after selecting ‘select’ next to the font of the document type.

I believe this because I changed plain text documents, which now have this weird behaviour and did not change the rich text documents which work as expected.

How on earth can I stop it doing this?
Can I reset the preferences to ‘factory settings’
Or clear some kind of .plist or something…

I may have solved the problem by highlighting the text in a plain text document in ‘normal’ view (or is that preview) then using the context menu to select ‘show colors’ and re-setting the color there.

I only had to do it in one document - weird behaviour has now stopped - phew.