Text search stopped working

I’ve always relied heavily on text search to find documents (rich text or scanned PDFs).

Recently the text search seems to have stopped working altogether. The search finishes, but nothing is shows in the search list. The search terms are words I know are there and I can manually find.

I tried emptying the cache, rebuilding the db, etc. Nothing I’ve tried makes it work again.

DT Pro Office Version 2.10.1
Fully licensed copy.

Any suggestions?


Do you use the toolbar search or the search window? In addition, which settings do you use?

Hi All,

I have the same problem with Devonthink 3 Pro.
the search (toolbar) does not find words within searchable PDFs. If I select the document and search within the document, then it finds the word and highlight it.

Even with Devonthink created formated notes are not searchable.

The document titels are searchable in Toolbar search. What is my mistake?


What’s the scope of the toolbar search? In addition, the toolbar search looks for complete words by default but searching in documents also accepts partial matches.

The scope is “All Databases”.
I tried both and searched for complete words and parts

A screenshot showing the scope and the entered search term would be useful. Plus a screenshot of the same search using the Search inspector.

The global search brings 4 Emails but not the bill which contains the word.
To be more precisely: it finds it in the file name but not in the content (the bill has another file name but the search term in the content)

Unfortunately i cannot upload more or replay from now on because of the limitation as a new user

If you’re looking for content, it’s best to specify that as criteria, like so…

Also, if this is an older database, you could make sure your backups are current and do a File > Rebuild Database on it.

i tried it (content / name) but without any result. Maybe it is the best to rebuild the database. When i do this, does it mean all folders get new IDs?
Background for this question: I have hazel rules to directly file documents to certain folders in DTP.

in addition to my previous post:
Now i do a global search with the title which contains the words and within the document it finds what I’m looking for:

No a rebuild doesn’t create new UUIDs for the items.

So you’re up and running now?

I’m still rebuilding. Will send an update very soon. Thank you for helping me!

It’s why we’re here :slight_smile:

I think i messed it up … i did the rebuild, but now it shows just 10% of the documents. the database hast still the same size as before. repair does not help too.

OK, the search is now my smalest problem … the database is still complete and i have backups. so no data loss :slight_smile:
rebulding does not bring the documents back. Is it possible to create a news database and import my documents and keep my old structure?

A restore point is created when you start a rebuild.
Hold the Option key and choose File > Restore Backup choosing a previous date. Note the Size too.

Lucky me, TimeMachine has a complete backup and i recover it now … :slight_smile:

Finally i rebuild my database and the best: the search is working perfect again! Thank you for helping me :slight_smile:

You’re welcome :slight_smile: